一个捆饶我很就的问题,跪求解答...(在线等,不胜感激)

ddwwyyll2002 2004-09-21 01:35:37
我在手机程序中用到了 java.util.LinkedList和java.util.Iterator这两个类;
我把原文件放在wtk,src目录下编译.出错,提示找不到这两个class,
我就把j2sdk下的包含有这两个class的一个叫rt.jar的文件,放在wtk相应的app的lib下,还是不能编译,提示:
Error preverifying class javax.security.auth.kerberos.KerberosKey
java/lang/NoClassDefFoundError: javax/crypto/SecretKey
Build failed

求各位大哥帮忙...
我知道要程序编译通过,就需要这两个class,但我不知道在wtk中怎么导入这个包,,
...全文
194 点赞 收藏 13
写回复
13 条回复
切换为时间正序
当前发帖距今超过3年,不再开放新的回复
发表回复
ddwwyyll2002 2004-09-24
谢谢各位大哥,耐性解答,
小弟最后还是自己写了个List,总算ok了,,,,,

回复
nik_Amis 2004-09-23
up
回复
shadowDLL 2004-09-22
学习中.............
回复
yexing 2004-09-22
同意ashram,即使你便以通过了,预审也不会通过的,因为kvm本身就不支持这两个类的实现,可以把javamappy里面的list类拿来用
回复
ashram 2004-09-22
有个Device下拉列表的啊,里面有这个wtk所包含的sdk,如果没有的话可以选DefaultColorPhone.我们编译moto的机器都用这个的
回复
王旺旺旺 2004-09-22
WTK怎么选择SDK?
回复
ashram 2004-09-21
java.util.LinkedList和java.util.Iterator这两个类都是j2se里的,而手机上的j2ME是不支持的,这个涉及到两种java虚拟机的实现上。有兴趣的可以反编译这两种java虚拟机的相同类比如Image类来做个比较。所以唯一的解决办法就是不用java.util.LinkedList和java.util.Iterator,或者自己写个类实现这两个类的功能而不能直接用SE里的类!!
另外chengfeng(匆匆过客,乘风归去) :其实jb用的也是WTK,而且WTK也是可以选SDK的。
回复
lxxldd 2004-09-21
我把原文件放在wtk,src目录下编译.出错,提示找不到这两个class,

------------------------------------------------
你只需把.java文件放在下面即可
回复
lumber 2004-09-21
把这两个类从JDK中解压出来和原来的程序放在同一目录下。

个人觉得这样做不如自己写一个功能一样的类。

回复
songsihua888 2004-09-21
我也关注.



大家好:
我有一个J2ME的手机游戏项目,急找人兼职,最好能带几个人一起开发,我们是上海的.
你有意思的话,与我联系.13917324163

MSN:dircddir@etang.com
回复
fch416668 2004-09-21
up
回复
chengfeng 2004-09-21
建议不要用WTK编译,WTK虽然能编译却缺乏调试手段,建议用功能较强的JB

这个问题如果是在JB中出现就是SDK没有选好,在JB中是可以自由选择当前SDK的。

另外,男人一跪千金,千万莫随便跪求~
回复
ddwwyyll2002 2004-09-21
自己顶一下...
回复
相关推荐
发帖
J2ME
创建于2007-09-28

1.3w+

社区成员

Java J2ME
申请成为版主
帖子事件
创建了帖子
2004-09-21 01:35
社区公告
暂无公告