初学遇到问题1,关于jad文件中cldc版本

ahduo 北京星桥通科技有限公司 研发部经理  2004-09-22 03:27:25
用eclisp开发的时候,创建程序时没有选择cldc,所以默认了1.1
但是我的手机支持midp2.0但是不支持1.1,程序下载了也不能用
所以我手动改jad文件,把cldc版本改为1.0,于是手机上可以用

但是我想问一下实际应该是用什么机制来确定我程序里面是只用到1.0而没有1.1没有呢?
我简单看了一下,eclipse里面可以设置libraries,但是这样改是正确的方法么?
...全文
104 点赞 收藏 2
写回复
2 条回复
切换为时间正序
当前发帖距今超过3年,不再开放新的回复
发表回复
ahduo 2004-09-22
谢谢
我看了一下,如果我在eclipse里面新建project的时候,只有midp1.0和2.0两个选项
但是选2.0以后,程序属性里面,java build path设置libraries的地方,里面用的是
cldcapi11.jar
这样是不是就不对啊?是不是应该手动改为cldcapi10.jar么?
回复
mingjava 2004-09-22
AMS会通过检查cldc midp的版本来确认是否安装你的MIDlet suite.因此你必须在jad文件中保证这两个参数和手机支持的兼容。如果你的程序中没有用到cldc1.1的api的话 那么就可以运行。cldc1.1比1.0多加了一些功能,比如float point的支持等
回复
相关推荐
发帖
J2ME
创建于2007-09-28

1.3w+

社区成员

Java J2ME
申请成为版主
帖子事件
创建了帖子
2004-09-22 03:27
社区公告
暂无公告