我的JBuilder为什么使用起来这样的别扭

csdndephi1 2004-09-26 05:29:20
说起来也真的有意思,用过了这么多的文字编辑器,但是没有一个像在JBuilder里面写代码这样别扭的

在我的机子上面,情况是这样的
如下面这段代码:

private void jbInit() throws Exception {
.....
this.setSize(new Dimension(400, 300));
.....
}
我在这里要说的是光标和字符不同步的问题,当我把上面这行代码输完的时候,光标在这里

30(光标位置)0;

我考,我就弄不明白了,为什么光标停在了两个0之间,
还有,当我进行删除的时候,情况就也很奇怪,

(光标位置)300;
当光标停在3前面,此刻当我按下Delete键,我考,300的最后一个0被删除了,

我对自己机子上出现的情况很纳闷,不知道在大家的机子上情况是怎么样的?
我很想知道情况,说说大家机子上的情况。:)

等待中......................................
...全文
125 8 打赏 收藏 举报
写回复
8 条回复
切换为时间正序
当前发帖距今超过3年,不再开放新的回复
发表回复
dlglmf 2004-09-27
  • 打赏
  • 举报
回复
这是jb的遗传问题,但是到了2005就基本解决了,2005以前的版本你可以设置一下颜色就可以了,tool->preference,选到其中的color标签,选Java标签下的“Reserved word”把右边的“Bold”去掉
这样就解决了你普通的文本编辑,但是如果要觉得 jsp的,还要修改jsp里面的颜色,在一个地方,去试试
ntzls 2004-09-27
  • 打赏
  • 举报
回复
以下文章引用自www.chinajavaworld.com java中文网
大家常常说JBuilder在中文系统中存在光标错位的问题,都认为这是JBuilder
的一个Bug,其实这实在是冤枉JBuilder了!大家讨论出来的解决方法无外乎
两种:
1、将编辑器的字体改为宋体,用这种方法带来的问题是,在宋体下的英文字
体实在难看,阅读起来不太顺眼;
2、就是将编辑器字体的粗体属性去掉,这样也影响代码的可读性。
其实,造成JBuilder光标错位的问题并不是Borland的错误,而是Java的宗
师——Sun的罪过!大家一定知道i18n吧?在不同的区域设置中,JDK自动调
用与之相对应的properties文件,而在JDK中,Sun所推出的与中文系统相对
应的properties文件存在问题,在它之中没有区分英文字体的正
常、粗体和斜体,从而导致了以上所说的问题,解决的方法很简单,只要将这
个properties文件修改正确就可以了,修改方法如下:
在jre/lib目录中找到font.properties.zh文件,编辑这个文件并修改成如下内容:

保存后,一切问题就解决了!
这种方法也适用于任何相同的问题。
[题外话]这种错误SUN真的应该好好反省一下了,希望以后他们做的东西能够
测试更好一些,不然……
bp69 2004-09-27
  • 打赏
  • 举报
回复
这其实是sun的java的问题
icy_csdn 2004-09-27
  • 打赏
  • 举报
回复
修正JBuilder编辑器光标位置不准确问题
====================================================

安装完JBuilder后
用记事本打开"C:\JBuilderX\bin\jbuilder.config"文件,
在文件中找到"vmparam"配置语句,加上下面一行,(设置Java虚拟机参数)

vmparam -Dprimetime.editor.useVariableWidthFont=true

保存后,删除Documents and Settings\Administrator目录下的 .primetimeX .jbuilderX(就是将jbuilder生成的文件全部删了)


就可以解决JBuilder编辑器光标位置不准确问题!重启。

如果不想这样解决也可以设置字体里把所有的粗体去掉。
robin0925 2004-09-27
  • 打赏
  • 举报
回复
那你用jb5.0,会好点!
ntzls 2004-09-26
  • 打赏
  • 举报
回复
设置一下即可
http://community.csdn.net/Expert/FAQ/FAQ_Index.asp?id=182595

也不知为何默认设置是这个别扭的,第一次用时也搞不懂,又不是因为中文。
trk_computer 2004-09-26
  • 打赏
  • 举报
回复
在编缉处点右键,选其中的“Editor Options”,选到其中的color标签,选Java标签下的“Reserved word”把右边的“Bold”去掉问题就解决了
bp69 2004-09-26
  • 打赏
  • 举报
回复
呵呵,搞笑,以前没用过jbuilder的,这个问题在jb2005以前的版本(jbx,jb9,jb8)都有的
可以下载一个东西,覆盖..,就好了
相关推荐
发帖
Java

4.9w+

社区成员

Java相关技术讨论
javaspring bootspring cloud 技术论坛(原bbs)
社区管理员
  • Java相关社区
  • 小虚竹
  • 谙忆
加入社区
帖子事件
创建了帖子
2004-09-26 05:29
社区公告
暂无公告