各位大侠请帮帮小妹的忙!简单问题.高分!

kelinwang19 合肥新加坡创新科技 软件工程师  2004-10-27 12:46:23
大侠有用过eclipse吗?我用的是eclipse3.0.1并且下载了eclipseme4.5以及最新的5.5并且装了wtk2.1.我把eclipseme4.5解压到eclipse的plugin目录下,点击file->import选择插件但为什么不行,请问大侠是怎么配置的,小妹刚毕业,工作需要学习j2me.请各位大侠帮忙指教!小妹感激不尽!
...全文
94 点赞 收藏 7
写回复
7 条回复
切换为时间正序
请发表友善的回复…
发表回复
kuhaijiaoyang 2004-11-01
那位大侠 能告诉我 我怎么提问啊!!我有好的问题想问 但是不知道怎么问啊!!谢谢帮忙!!!~!~
回复
batfree 2004-11-01
看ECLIPSE ME的帮助文件,很详细的。而且将相应的EclipseME文件解压到plugin文件夹里就行了,
回复
lumber 2004-10-30
http://blog.csdn.net/chinamao/archive/2004/10/21/146193.aspx
回复
网络咖啡 2004-10-30
http://dev.csdn.net/article/35/35572.shtm
回复
Javask 2004-10-30
用Jbuilder X或者jcreator,eidtplus都行吧
eclipse不太会...

参考以下用法:

http://blog.csdn.net/mingjava/archive/2004/06/23/24022.aspx
http://blog.csdn.net/mingjava/archive/2004/06/23/24022.aspx
http://www.everenter.com/bbs/dispbbs.asp?boardID=5&ID=552
http://www.knowsky.com/4090.html
http://jjhou.csdn.net/upload/midpbasic.zip
WTK+UE的J2ME开发环境

所需软件:
1、java运行环境:j2sdk 1.4.1 <http://java.sun.com/j2se/downloads/index.html>
2、sun提供的无线开发工具包:j2me wireless toolkit 2.1 <http://java.sun.com/products/j2mewtoolkit>
3、诺基亚j2me开发套件:Nokia Developer's Suite 2.0 for J2ME
S40模拟器:Nokia 7210 MIDP SDK v1.0
S60模拟器:Series60 MIDP Concept SDK Beta 0.3 Nokia edition
或安装Series 60 MIDP SDK 2.1(Series_60_MIDP_SDK_for_Symbian_OS_v_1_0)
4、代码编辑器:UltraEdit32
5、混淆器:proguard 1.62

安装过程:
1. 安装j2sdk 1.4.1
2. 安装wtk2.1
3. 安装Nokia Developer’s Suite 2.0 for j2me。
将两个模拟器的目录复制到wtk模拟器目录下
4. 安装UltraEdit32。
在Configuration中将Tab设置为4,Backup设置为No Backup。
5. 解压混淆器,将proguard.jar复制到wtk的bin目录下。

开发过程:
1. 运行wtk。创建一个项目。
2. 在UE中创建一个项目。并将wtk创建的src目录添加进来。
3. 增加、编辑、保存.java文件。注意文件名与类名一样。
4. 在wtk中Build。出错则到3,通过则到5。
5. 然后,选择一个模拟器,Run。
6. 调试通过后,执行Project->Package->Create Obfuscated Package。使用混淆器能使jar的大小缩小15%左右。
7. 在项目的bin目录取出jad和jar进行发布。






要进行J2ME的开发,首先必须要建立开发的平台,而在开发的平台选择上,有四种方案。

一、功能比较全的Borland Jbuilder平台(推荐使用)
搭建这个平台,我们必需要安装:JBUILDER 7、JBUILDER 8 或 JBUILDER 9,BORLAND 的 MOBILESET 3.1。可选材料有:(注意这些不是必须的,没有这些你也可以进行开发)你所想开发的手机SDK,例如要在NOKIA上开发必须准备NOKIA DEVELOPER‘S SUITE,还可以根据自己需要加一些模拟器如7210等。
有了以上的材料就足够我们搭建一个很不错的开发平台了。
搭建步骤:
(1):安装JBUILDER,并注册。(如果是安装了JBuilder 9.0, 且是完全安装, 则不必安装MobileSet 3.1, 可以直接跳到步骤3)
注意:JBuilder的安装目录名称不能含有空格(如: 不能安装在Program Files目录中,因为中间有空格),最好安装在默认的目录中。JBuilder倒不会因为空格出问题,等下一步安装MOBILESET 3.1时,到最后会由于空格出现问题。
(2):正确安装JBUILDER ,并成功注册后,安装 MOBILESET 3.1,安装完成后,需要注册,MOBILESET是免费的,你可以向BORLAND索要注册码,也可以用 附录2 中的注册码注册。
注意:安装MOBILESET 3.1时用自定义方式(Custome)安装,安装时第二项(RetroGuard Obfuscator)不选择。
(3):完成以上2步必须步骤后,就可以安装你选装的DEVELOPER'S SUITE和模拟器了(NOKIA SDK安装方法见附录1)。
(4):正确完成了以上步骤,可以说这个平台已经搭建完成,就这么简单,下面你要做的就是在JBUILDER中NEW 一个PROJECT,在出现的窗体中JDK选J2ME的,其他都使用默认的就可以了,完成配置后,再选NEW,这时候在最后的MIDP页面里两个选项应该是可选的,接下来你就可以开发了。

二、使用Sun 公司官方工具,无线开发平台 j2me_wireless_toolkit
搭建这个平台,我们必需要安装有:jdk1.4,j2me_wireless_toolkit1.04或j2me_wireless_toolkit2.0可选材料有:(注意这些不是必须的,没有这些你也可以进行开发)你所想开发的手机SDK,例如要在NOKIA上开发必须准备NOKIA DEVELOPER‘S SUITE,还可以根据自己需要加一些模拟器如7210等(NOKIA SDK安装方法见附录1)。
有了以上的材料就足够我们搭建现在的平台。
(1):首先安装jdk1.4,(在方法一中因为JBUILDER自带JDK所以不需要单独安装。)
(2):正确安装JDK后,才可以安装j2me_wireless_toolkit,不管1.04还是2.0,都可以,2个都装也可以。
(3):完成以上2步必须步骤后,就可以安装你选装的DEVELOPER’S SUITE和模拟器了(NOKIA SDK安装方法见附录1)。
(4)正确完成了以上步骤,可以说这个平台已经搭建完毕了(j2me_wireless_toolki的作用和JBUILDER差不多,用来编译你写的JAVA程序,但它本身不提供编辑等功能,所以你得用记事本或其他文本编辑软件写程序,使用方法见附录3)

三、使用Sun 公司集成开发环境Forte For Java+J2ME_Wireless_Toolkit(推荐使用)
搭建这个平台,我们必需要安装有:Java2 SDK(Java2 Standard Edition),Fore For Java Community Edition, J2ME_wireless_toolkit1.03 可选材料有: (注意这些不是必须的,没有这些你也可以进行开发)你所想开发的手机SDK,例如要在NOKIA上开发必须准备NOKIA DEVELOPER‘S SUITE,还可以根据自己需要加一些模拟器如7210等(NOKIA SDK安装方法见附录1)。
有了以上的材料我们就搭建现在的平台。
(1):首先安装Java2 SDK(Java2 Standard Edition)。
(2):正确安装SDK后,才可以安装Fore For Java Community Edition。
(3):完成以上2步必须步骤后,就可以安装J2ME_wireless_toolkit1.03 (注意当安装到要选择安装模式时,是“Integrated”----集成, 还是“Alone”----独立,选择“Integrated”----集成)。
(4):完成以上2步必须步骤后,就可以安装你选装的DEVELOPER’S SUITE和模拟器了(NOKIA SDK安装方法见附录1)。
(5)正确完成了以上步骤,这个平台就搭建完毕(Fore For Java Community Edition的作用和JBUILDER差不多)

四、个头最小,但用起来比较复杂的平台cldc+MIDP
搭建这个平台,我们必需要安装:jdk1.4,J2ME_CLDC_ 1.04,MIDP 2.0
这个平台的使用比较复杂,只粗略的介绍一下:
(1)同样首先要安装jdk1.4
(2)将J2ME_CLDC_ 1.04,MIDP 2.0和解压到同一目录下如c:\j2me下,其实这两个就是在命令行下的编译器和JBUILDER,toolkit的作用一样,但用起来更麻烦。
(3)详细使用方法见附录4

回复
好象不需要用到吧,我没有用这个东西。
回复
民间导尿管 2004-10-27
一定要用eclipse吗,
回复
发动态
发帖子
J2ME
创建于2007-09-28

1.3w+

社区成员

Java J2ME
申请成为版主
社区公告
暂无公告