jbuilder2005用到jdk1.5语法的问题。

trumplet 2004-10-31 08:58:43
使用了
int[] integers = new int[]{0,1,2,3,4,5,6,7,8,9};
for(int i:integers){
i = i*i;
}

错误提示是:
"Test.java": for-each loops are not supported in -source 1.2 (try -source 1.5 to enable for-each loops) at line 13, column 26

请问,我应该到哪里去设“-source 1.5”呀?
...全文
81 3 打赏 收藏 举报
写回复
3 条回复
切换为时间正序
当前发帖距今超过3年,不再开放新的回复
发表回复
trumplet 2004-11-01
  • 打赏
  • 举报
回复
解决了!。谢谢!。
naxin 2004-11-01
  • 打赏
  • 举报
回复
在project属性中,设为编译支持1.5, 并用1.5运行.

当然你要先设好jdk 1.5
honeyrabbit 2004-10-31
  • 打赏
  • 举报
回复
使用JDK1.5,支持for(int i:integers)这种用法。
相关推荐
发帖
Java

4.9w+

社区成员

Java相关技术讨论
javaspring bootspring cloud 技术论坛(原bbs)
社区管理员
  • Java相关社区
  • 小虚竹
  • 谙忆
加入社区
帖子事件
创建了帖子
2004-10-31 08:58
社区公告
暂无公告