Microsoft Java 虚拟机……支持jdk到哪个版本啊?

BabyWhite 2006-02-28 11:52:53
随便写了一个最简单的Applet,用Maxthon打开,结果说找不到class ...
奇怪的是,用IE打开又没有问题。
后来发现,在“Maxthon 选项”->“高级”中,有一个选项可以让你选择使用Microsoft Java虚拟机还是系统安装的其它Java虚拟机
如果选择Microsoft Java虚拟机就显示不了,但选择“系统安装的其它虚拟机”就没有问题。

开始我以为是我的JDK太高版本了,编译出来的class Microsoft虚拟机识别不了,但安装JDK1.4.2编译后再试也是不行……晕

请问,Microsoft Java虚拟机支持Java有多少啊?
我的IE是6.0版本的^_^
...全文
40 点赞 收藏 3
写回复
3 条回复
切换为时间正序
当前发帖距今超过3年,不再开放新的回复
发表回复
woxiangwalkman 2006-02-28
微软的虚拟机可以兼容的是JDK1.3,你只要用JDK1.3编译就可以了,但是这样你就不能不使用JDK1.3以后的特性了
回复
BabyWhite 2006-02-28
呵呵,问题是,我想要我写的Applet有最大的兼容性嘛……^_^
比如我同学机上就没有安装其它的虚拟机,在他机上就显示不了这个Applet
你不能要求人家机上一定要有什么,也不能要求人家要有什么特殊设置嘛
所以我想知道怎么才能开发出最大兼容性的Applet来^_^
回复
cathl 2006-02-28
问题不是支持到多少。即使版本完全一样,两个JVM的路径也不一样。
必须选定路径为你所安装使用的JVM,也就是和环境变量里设定的一致
回复
相关推荐
发帖
Web 开发
创建于2007-09-28

8.0w+

社区成员

Java Web 开发
申请成为版主
帖子事件
创建了帖子
2006-02-28 11:52
社区公告
暂无公告