在wtk模拟器上能运行,在motorola模拟器里运行不了

leos2000 2006-03-02 04:28:53
在eclipse里用j2me写了个小游戏,可以在wtk的模拟器上运行,但是用motorola模拟器运行时却显示class check failed ,这是咋回事呀?是不是和预验证有关呀?高手赐教,谢谢啦。
...全文
108 6 点赞 打赏 收藏 举报
写回复
6 条回复
切换为时间正序
当前发帖距今超过3年,不再开放新的回复
发表回复
xiaoyaose 2006-03-08
根据我的经验,wtk运行是不需要deployed下面的东东,它是读取的项目目录下面的那个.jad文件,然而对于摩托和诺基亚都是需要用到deployed文件夹下面的.jad文件的,所以我猜想是你没有生成deployed文件夹。

至于如何得到这个文件夹的东东,最简单的办法就是右键单击该项目->J2ME->Create Package,这样就会生成一个deployed文件夹,然后对于moto的模拟器,就指定位置为该文件夹下面的.jad文件,就可以运行成功了。
  • 打赏
  • 举报
回复
xiaoyaose 2006-03-07
根据我的经验,wtk运行是不需要deployed下面的东东,它是读取的项目目录下面的那个.jad文件,然而对于摩托和诺基亚都是需要用到deployed文件夹下面的.jad文件的,所以我猜想是你没有生成deployed文件夹。
本人在eclipse里面建项目时,在选择plantform definations时选用诺基亚的任何一款平台,然后写完程序之后,运行一次,之后你再试着用motorola模拟器来运行,应该就可以成功的。

本人也是菜鸟,可能还有更好的方法,希望达人赐教!
  • 打赏
  • 举报
回复
aloney0226 2006-03-05
路径要英文
  • 打赏
  • 举报
回复
theLast_ 2006-03-03
在模拟器运行不能打混淆包
  • 打赏
  • 举报
回复
leos2000 2006-03-02
jad里没有中文。不用包也不行。
  • 打赏
  • 举报
回复
贝壳鱼 2006-03-02
不要用包,JAD 里不能有中文
  • 打赏
  • 举报
回复
相关推荐
发帖
J2ME
创建于2007-09-28

1.3w+

社区成员

Java J2ME
申请成为版主
帖子事件
创建了帖子
2006-03-02 04:28
社区公告
暂无公告