关于jdk1.5 + tomcat5.0.28 + eclipse3.1开发的问题。

bianchengxiaozi 2006-03-09 05:05:04
请问各位高手为什么我升级了jdk以后原来用eclipse开发的structs程序运行的时候出现org.apache.jasper.JasperException: Unable to compile class for JSP错误,换成jdk1.4之后就可以了,原来是用1.4开发的。
...全文
132 点赞 收藏 9
写回复
9 条回复
切换为时间正序
当前发帖距今超过3年,不再开放新的回复
发表回复
leekooqi 2006-03-10
我也碰到过,可能是jdk1.5 + eclipse3.1集成的不稳定。
回复
bianchengxiaozi 2006-03-10
给分。
回复
bianchengxiaozi 2006-03-10
谢谢大家,问题解决了,下载了一个tomcat5.5就可以了。
回复
是JDK本身版本不兼容的问题
感觉JAVA这方面很不正规
回复
bianchengxiaozi 2006-03-10
tomcat5.5一定可以吗,我试试看。

To:nationally(自由鸟)
我开发GUI程序没有问题,只是和Tomcat一起使用的时候就有问题了。
回复
dogod 2006-03-09
有可能是包不匹配造成的,startup.bat里加上set java_home=%yourJDK1.5path% ,
还要看看你环境变量classpath设的对不对;
还不行就重装一个tomcat5.5吧
回复
ibiswang 2006-03-09
Tomcat版本太低吧,用 Tomcat 5.X试试!!

回复
bianchengxiaozi 2006-03-09
我已经替换了呀,还是老问题,是不是要设置一下环境变量呀。
回复
polarman 2006-03-09
将jdk1.5中的tools.jar拷贝到{Tomcat_Home}/common/lib下覆盖老的,老的是jdk1.4的
回复
相关推荐
发帖
Web 开发
创建于2007-09-28

8.0w+

社区成员

Java Web 开发
申请成为版主
帖子事件
创建了帖子
2006-03-09 05:05
社区公告
暂无公告