遇到一个水晶报表的奇怪的问题

xiaogua 2006-10-24 04:16:27
我的系统里有.NET2003的水晶报表VIEW9.1.5也有水晶报表2.3.3的组件,在我写的一个测试程序里,这个VIEW可以显示出来,但是我将它合到我的正式的程序里,就出现版本不兼容的错误了
基类包括字段“CrystalReportViewer1”,但其类型(CrystalDecisions.Web.CrystalReportViewer)与控件(CrystalDecisions.Web.CrystalReportViewer)的类型不兼容。

源错误:


行 13: <form id="Form1" method="post" runat="server">
行 14: <FONT face="宋体">
行 15: <cr1:CrystalReportViewer id="CrystalReportViewer1" style="Z-INDEX: 101; LEFT: 16px; POSITION: absolute; TOP: 16px"
行 16: runat="server"></cr1:CrystalReportViewer></FONT>
行 17: </form>

出现这种情况是什么原因啊,在我的测试程序里又没有出错~.
你们有遇到过这样的问题吗?
...全文
62 回复 打赏 收藏 举报
写回复
回复
切换为时间正序
当前发帖距今超过3年,不再开放新的回复
发表回复
相关推荐
发帖
.NET社区

6.1w+

社区成员

.NET技术交流专区
javascript云原生 企业社区
社区管理员
  • ASP.NET
  • .Net开发者社区
  • R小R
加入社区
帖子事件
创建了帖子
2006-10-24 04:16
社区公告

.NET 社区是一个围绕开源 .NET 的开放、热情、创新、包容的技术社区。社区致力于为广大 .NET 爱好者提供一个良好的知识共享、协同互助的 .NET 技术交流环境。我们尊重不同意见,支持健康理性的辩论和互动,反对歧视和攻击。

希望和大家一起共同营造一个活跃、友好的社区氛围。