2003系统+IIS6上asp.net网站无法访问(急,100分在线求高手帮助)

joenren 2009-09-08 10:24:28
服务器:2003操作系统+IIS6,服务器上已经安装了.net framework2.0 .net站也建立了独立应用池,IIS里网站也已经将版本选择为2.0.50727. 网站的权限方面也已经赋予了ASP.NET、IWAM_MachineName、Local_Service、Network_Service、System而且权限要设置为write & read.

现在现象为:
1、访问.net这个网站时出现:"Server Application Unavailable
The web application you are attempting to access on this web server is currently unavailable. Please hit the "Refresh" button in your web browser to retry your request.

Administrator Note: An error message detailing the cause of this specific request failure can be found in the application event log of the web server. Please review this log entry to discover what caused this error to occur.

2、服务器日志上:"Failed to execute request because the App-Domain could not be created. Error: 0x80004005 未指定的错误 "  事件ID(I):1088

3、服务器上asp站点全部可以正常访问.

已经重新安装过.net framework2.0

望在线的高手指点,感激不尽!
...全文
659 17 打赏 收藏 转发到动态 举报
写回复
用AI写文章
17 条回复
切换为时间正序
请发表友善的回复…
发表回复
joenren 2009-09-14
  • 打赏
  • 举报
回复
对于我服务器上出现的问题,现在有个情况是,如果我把应用程序池里的标识由"网络服务"改为"本地系统"就可以正常访问,我感觉还是权限那里出问题,继续想办法解决中.........
joenren 2009-09-14
  • 打赏
  • 举报
回复
还是没解决,前面为了不耽误网站开通,去www.086sj.cn那去开了个空间,结果是个骗子,才几天就关了,希望大家不要再被骗.以下是那家公司的信息.

武汉网科电子商务有限公司
  
  
  地址:湖北省武汉市徐东路7号徐东综合楼2单元1003室
  
  电话:027-86732102 027-86824861
  
  http://www.wk35.com
  
  E-mail:35wk@163.com
  
  营业执照:4201002139920
  
  税务登记:420111783169039

司帐户 银 行:中国银行徐东支行 行号: 846727
  名 称:武汉网科电子商务有限公司
  账 号:15678608091001
  
  中国银行 银 行:中行
  帐 号:4563 5130 0031 5927 106
  户 名:杨得慷
  
  农业银行 银 行:农行
  帐 号:6228 4800 5054 0365 215
  户 名:杨得慷
  
  建设银行 银 行:建行
  帐 号:6227 0028 7227 0036 380
  户 名:杨得慷
  
  招商银行 银 行:招行
  帐 号:6225 8827 0117 2097
  户 名:杨得慷
  
  民生银行 银 行:民生
  帐 号:6226 2205 8010 8487
  户 名:杨得慷
  交通银行 银 行:交行
  帐 号:6222 6006 1000 7356 243
  户 名:杨得慷
  
  wk35@yahoo.cn
fangyuan303687320 2009-09-14
  • 打赏
  • 举报
回复
下载一个微软的.net framework 全部卸载工具,在官网能找。。
将机器上的.net 全卸载掉。
再得新装一遍
Ny-6000 2009-09-14
  • 打赏
  • 举报
回复
现在解决了吗?
joenren 2009-09-11
  • 打赏
  • 举报
回复
分开的,不行,郁闷啊,还是无法解决
chenhanjun007 2009-09-09
  • 打赏
  • 举报
回复
我以前遇见过当用VS2003开发的项目和用vs2008开发的项目用一个连接池的时候好像就会报这样的错误!
最后就把他们分开用不同的池!
joenren 2009-09-08
  • 打赏
  • 举报
回复
先准备吃饭,完了继续等待高手出现,自己顶起............
joenren 2009-09-08
  • 打赏
  • 举报
回复
1.1的我已经删除了,站点配置的属性里面选择的时候就已经只有2.0了
sy_binbin 2009-09-08
  • 打赏
  • 举报
回复
你的服务器是不是安装了1.1的框架阿
在IIS的站点,右键属性,看看ASP.NET的版本是什么??
joenren 2009-09-08
  • 打赏
  • 举报
回复
等待中............
joenren 2009-09-08
  • 打赏
  • 举报
回复
IUSR_用户都有权限了,包括写入权限都开起的.
starwu 2009-09-08
  • 打赏
  • 举报
回复
看看ISAPI应用程序有没有.ASPX的映射
IUSR_ 用户名有没有权限?
joenren 2009-09-08
  • 打赏
  • 举报
回复
对了,补充下,如果将应用池里标识由"网络服务"改为"本地系统"后网站可以访问,自己感觉是权限问题,但改了各种权限还是上面的错误提示.
joenren 2009-09-08
  • 打赏
  • 举报
回复
.net启动了的
ximengchang 2009-09-08
  • 打赏
  • 举报
回复
web扩展中的。net启用了吗?
joenren 2009-09-08
  • 打赏
  • 举报
回复
楼上的方法我前面已经处理过,不行.

现在自己按http://support.microsoft.com/kb/811320/zh-cn上面的介绍没出现前面的问题,但网站还是无法访问,查看日志发现应用程序池的一些错误提示,并会出现访问几次网站后.net这个站的应用程序池出现停止现象.

日志如下:
事件ID(I):1009   为应用程序池 'AppPool #net' 提供服务的进程意外终止。进程 ID 是 '1140'。进程退出代码是 '0xc06d007e'。

为应用程序池 'AppPool #net' 提供服务的进程意外终止。进程 ID 是 '708'。进程退出代码是 '0xc06d007e'。

为应用程序池 'AppPool #net' 提供服务的进程意外终止。进程 ID 是 '1332'。进程退出代码是 '0xc06d007e'。

为应用程序池 'AppPool #net' 提供服务的进程意外终止。进程 ID 是 '3320'。进程退出代码是 '0xc06d007e'。

为应用程序池 'AppPool #net' 提供服务的进程意外终止。进程 ID 是 '2912'。进程退出代码是 '0xc06d007e'。

应用程序池 'AppPool #net' 被自动禁用,原因是为此应用程序池提供服务的进程中出现一系列错误。
sy_binbin 2009-09-08
  • 打赏
  • 举报
回复
你参考这个网站的操作试试
http://blog.csdn.net/zhangke0504/archive/2009/02/09/3869773.aspx

5,657

社区成员

发帖
与我相关
我的任务
社区描述
Web开发应用服务器相关讨论专区
社区管理员
  • 应用服务器社区
加入社区
  • 近7日
  • 近30日
  • 至今
社区公告
暂无公告

试试用AI创作助手写篇文章吧