linux下面80、81、79这样的小端口如何使用啊?

kaixinmengya 2010-01-25 08:23:01
我是用weblogic想把端口改为80,但是系统提示我不能绑定80端口,出现一下显示:
<2010-1-25 下午03时59分59秒 CST> <Emergency> <WebLogicServer> <BEA-000351> <Unable to create a server socket on Channel Default for port: 80. java.net.BindException: Permission denied Perhaps another process is using port 80.>
<2010-1-25 下午03时59分59秒 CST> <Emergency> <Security> <BEA-090085> <Server failed to bind to the configured port. The port may already be used by another process.>
<2010-1-25 下午03时59分59秒 CST> <Emergency> <WebLogicServer> <BEA-000342> <Unable to initialize the server: Server failed to bind to the requested port. See preceeding log message for details.>
***************************************************************************
The WebLogic Server did not start up properly.
Exception raised: 'weblogic.server.ServerLifecycleException: Server failed to bind to the requested port. See preceeding log message for details.'
Reason: Server failed to bind to the requested port. See preceeding log message for details.
***************************************************************************
[weblogic@localhost mydomain]$ netstat -an |grep 80
tcp 0 0 ::ffff:76.16.17.79:32857 ::ffff:76.16.17.80:1521 TIME_WAIT


我检查了一下并没有看到80端口,后来发现81、79这样的小端口都无法使用,我感觉好像是linux不允许我的weblogic用户绑定1024位以下的端口,我想应该是只有root权限的用户才能绑定吧,所以我把weblogic用户里添加了root群组,但是还是无法绑定80端口,请大家帮忙看看这是为什么呢?应该如何解决呢?
谢谢大家了先~
...全文
233 3 打赏 收藏 转发到动态 举报
写回复
用AI写文章
3 条回复
切换为时间正序
请发表友善的回复…
发表回复
phoenixYiYou 2010-02-09
  • 打赏
  • 举报
回复
明显还是被占用了,否则你用netstat -an |grep 80查实没有显示的,你明白吗?呵呵!
kaixinmengya 2010-02-08
  • 打赏
  • 举报
回复
⊙﹏⊙b汗
kaixinmengya 2010-01-26
  • 打赏
  • 举报
回复
没有人能帮忙分析一下吗?

5,657

社区成员

发帖
与我相关
我的任务
社区描述
Web开发应用服务器相关讨论专区
社区管理员
  • 应用服务器社区
加入社区
  • 近7日
  • 近30日
  • 至今
社区公告
暂无公告

试试用AI创作助手写篇文章吧