apache tomcat 整合问题

linux_DD 2010-02-26 11:15:29
在整合apache 和 tomcat 的时候出现了一些问题,大家帮忙给看一下。
我用的版本是
apache:apache_2.2.14-win32-x86-no_ssl
tomcat:apache-tomcat-5.5.28
connector:jakarta-tomcat-connectors-jk2.0.4-win32-apache2.0.49

步骤
1 把解压缩后的mod_jk2.so 放到 Apache 的 /modules 下面
2 在Apache的httpd.conf文件的最后一行添加如下
LoadModule jk2_module modules/mod_jk2.so
3 在apache的conf下创建workers2.properties文件,workers2.properties内容如下
[status:]
[uri:/jkstatus/*]
group=status:
[shm:]
disabled=1
[channel.socket:localhost:8009]
[ajp13:]
[uri:/tomcat-docs/*]   
4 启动tomcat,启动apache
5 tomcat正常启动了,可启动apache的时候出下面的错了
httpd.exe: Syntax error on line 483 of C:/Program Files/Apache Software Foundati
on/Apache2.2/conf/httpd.conf: Cannot load C:/Program Files/Apache Software Found
ation/Apache2.2/modules/mod_jk2.dll into server: 。。。。。。。。。

请问错误原因是什么呢。它写的是Syntax error on line 483 ,可那一行只有LoadModule jk2_module modules/mod_jk2.so
这已经确认过无数遍了,应该没问题啊。是还有什么没有设置么,还是我用的东西版本不对呢。麻烦高手给看一下,谢谢。
...全文
140 4 打赏 收藏 转发到动态 举报
写回复
用AI写文章
4 条回复
切换为时间正序
请发表友善的回复…
发表回复
linux_DD 2010-03-06
  • 打赏
  • 举报
回复
好的,谢谢了。看来没别人回答了,结了。
phoenixYiYou 2010-02-28
  • 打赏
  • 举报
回复
我理解也未必完全正确,抛砖引玉一下:整合后应该是全部都从tomcat下访问的,tomcat下的静态页apache来处理,动态的tomcat来处理。
至于你问的那几句话:应该是说tomcat默认用的8009端口的ajp13来负责和apache通讯的!在tomcat下的server.xml配置文件中,你可以看到ajp13的配置。呵呵!
linux_DD 2010-02-28
  • 打赏
  • 举报
回复
自己回答一下。
jakarta-tomcat-connectors-jk2.0.4-win32-apache2.0.49 是从apache上下的一个zip包,包括
整合时应该向apache得conf文件追加内容得sample,说明文档和mod_jk2.so,版本应该就是jk2.0.4。

问题我已经找到了,应该是jk和apache的版本不匹配。
从这个压缩包上可以看到,jk2.0.4应该是对应的是apache2.0的,可是我一开始用的是apache_2.2所以就出现cannot load的错了。

再问一个问题。
现在我已经可以通过apache的80端口直接访问发布在tomcat下的工程了。看网上的资料说这样因该就是初步整合成功了。但是我再去访问apache的默认页面,也就是http://localhost/的时候,出现的却是tomcat的默认页面,也就是http://localhost:8080/,感觉上是把所有的请求都转发到了tomcat了么?
整合后的状态因该是apache处理静态页面,tomcat处理servlet请求,这还需要特别的设置么,比如说写明tomcat只处理jsp之类的。还是说把工程都发布在tomcat下,在经由apache的时候静态页面就被自动识别并处理了呢?整合之后大家都把工程部署在什么地方呢?

workers2.properties文件的下面这几句可以帮忙解释一下么。
[channel.socket:localhost:8009]
[ajp13:]
[uri:/tomcat-docs/*]
好像只有放在这个uri下面的才能被访问。

有些乱,麻烦大家给解答下,谢谢。  

phoenixYiYou 2010-02-26
  • 打赏
  • 举报
回复
不大明白你用的jakarta-tomcat-connectors-jk2.0.4-win32-apache2.0.49 ??
现在整合都用如下
mod_jk-1.2.28-httpd-2.0.52.so这样的文件了,你没看到过介绍?
而且,我刚用如上的文件做过整合!呵呵!

5,657

社区成员

发帖
与我相关
我的任务
社区描述
Web开发应用服务器相关讨论专区
社区管理员
  • 应用服务器社区
加入社区
  • 近7日
  • 近30日
  • 至今
社区公告
暂无公告

试试用AI创作助手写篇文章吧