请问weblogic这是报的什么错误呢?

kaixinmengya 2010-03-09 09:46:11
weblogic启动的时候显示的内容如下,请大家帮忙看看这是什么错误呢?谢谢了先!

[weblogic@localhost mydomain]$ ./startWebLogic.sh
.
CLASSPATH=/home/weblogic/bea/jdk142_08/lib/tools.jar:/home/weblogic/bea/weblogic81/server/lib/weblogic_sp.jar:/home/weblogic/bea/weblogic81/server/lib/weblogic.jar::/home/weblogic/bea/weblogic81/common/eval/pointbase/lib/pbserver44.jar:/home/weblogic/bea/weblogic81/common/eval/pointbase/lib/pbclient44.jar:/home/weblogic/bea/jdk142_08/jre/lib/rt.jar:/home/weblogic/bea/weblogic81/server/lib/webservices.jar:/home/weblogic/bea/jdk142_08/jre/lib
.
PATH=/home/weblogic/bea/weblogic81/server/bin:/home/weblogic/bea/jdk142_08/jre/bin:/home/weblogic/bea/jdk142_08/bin:/usr/kerberos/bin:/usr/local/bin:/bin:/usr/bin:/usr/X11R6/bin:/home/weblogic/bin:/home/weblogic/bea/jdk142_08/bin
.
***************************************************
* To start WebLogic Server, use a username and *
* password assigned to an admin-level user. For *
* server administration, use the WebLogic Server *
* console at http://[hostname]:[port]/console *
***************************************************
<2010-3-9 下午02时20分02秒 CST> <Info> <WebLogicServer> <BEA-000377> <Starting WebLogic Server with Java HotSpot(TM) Client VM Version 1.4.2_08-b03 from Sun Microsystems Inc.>
<2010-3-9 下午02时20分02秒 CST> <Info> <Configuration Management> <BEA-150016> <This server is being started as the administration server.>
<2010-3-9 下午02时20分02秒 CST> <Info> <Management> <BEA-141107> <Version: WebLogic Server 8.1 SP5 Mon Sep 19 23:06:54 PDT 2005 641358
WebLogic XMLX Module 8.1 SP5 Mon Sep 19 23:06:54 PDT 2005 641358 >
<2010-3-9 下午02时20分02秒 CST> <Notice> <Management> <BEA-140005> <Loading domain configuration from configuration repository at /home/weblogic/bea/user_projects/domains/mydomain/./config.xml.>
<2010-3-9 下午02时20分03秒 CST> <Notice> <Log Management> <BEA-170019> <The server log file /home/weblogic/bea/user_projects/domains/mydomain/myserver/myserver.log is opened. All server side log events will be written to this file.>
<2010-3-9 下午02时20分03秒 CST> <Warning> <EmbeddedLDAP> <BEA-171520> <Could not obtain an exclusive lock for directory: ./myserver/ldap/ldapfiles. Waiting for 10 seconds and then retrying in case existing WebLogic Server is still shutting down.>
<2010-3-9 下午02时20分13秒 CST> <Warning> <EmbeddedLDAP> <BEA-171520> <Could not obtain an exclusive lock for directory: ./myserver/ldap/ldapfiles. Waiting for 10 seconds and then retrying in case existing WebLogic Server is still shutting down.>
<2010-3-9 下午02时20分23秒 CST> <Warning> <EmbeddedLDAP> <BEA-171520> <Could not obtain an exclusive lock for directory: ./myserver/ldap/ldapfiles. Waiting for 10 seconds and then retrying in case existing WebLogic Server is still shutting down.>
<2010-3-9 下午02时20分33秒 CST> <Warning> <EmbeddedLDAP> <BEA-171520> <Could not obtain an exclusive lock for directory: ./myserver/ldap/ldapfiles. Waiting for 10 seconds and then retrying in case existing WebLogic Server is still shutting down.>
<2010-3-9 下午02时20分43秒 CST> <Error> <EmbeddedLDAP> <BEA-171519> <Could not obtain an exclusive lock to the embedded LDAP data files directory: ./myserver/ldap/ldapfiles because another WebLogic Server is already using this directory. Ensure that the first WebLogic Server is completely shutdown and restart the server.>
<2010-3-9 下午02时20分43秒 CST> <Critical> <WebLogicServer> <BEA-000364> <Server failed during initialization. Exception:weblogic.server.ServiceFailureException: Could not obtain an exclusive lock to the embedded LDAP data files directory: ./myserver/ldap/ldapfiles because another WebLogic Server is already using this directory. Ensure that the first WebLogic Server is completely shutdown and restart the server.
weblogic.server.ServiceFailureException: Could not obtain an exclusive lock to the embedded LDAP data files directory: ./myserver/ldap/ldapfiles because another WebLogic Server is already using this directory. Ensure that the first WebLogic Server is completely shutdown and restart the server.
at weblogic.ldap.EmbeddedLDAP.ensureExclusiveAccess(EmbeddedLDAP.java:960)
at weblogic.ldap.EmbeddedLDAP.initialize(EmbeddedLDAP.java:222)
at weblogic.t3.srvr.T3Srvr.initializeHere(T3Srvr.java:815)
at weblogic.t3.srvr.T3Srvr.initialize(T3Srvr.java:669)
at weblogic.t3.srvr.T3Srvr.run(T3Srvr.java:343)
at weblogic.Server.main(Server.java:32)
>
<2010-3-9 下午02时20分43秒 CST> <Emergency> <WebLogicServer> <BEA-000342> <Unable to initialize the server: weblogic.server.ServiceFailureException: Could not obtain an exclusive lock to the embedded LDAP data files directory: ./myserver/ldap/ldapfiles because another WebLogic Server is already using this directory. Ensure that the first WebLogic Server is completely shutdown and restart the server.>
***************************************************************************
The WebLogic Server did not start up properly.
Exception raised: 'weblogic.server.ServiceFailureException: Could not obtain an exclusive lock to the embedded LDAP data files directory: ./myserver/ldap/ldapfiles because another WebLogic Server is already using this directory. Ensure that the first WebLogic Server is completely shutdown and restart the server.'
Reason: weblogic.server.ServiceFailureException: Could not obtain an exclusive lock to the embedded LDAP data files directory: ./myserver/ldap/ldapfiles because another WebLogic Server is already using this directory. Ensure that the first WebLogic Server is completely shutdown and restart the server.
***************************************************************************
[weblogic@localhost mydomain]$

...全文
1126 4 打赏 收藏 举报
写回复
用AI写文章
4 条回复
切换为时间正序
请发表友善的回复…
发表回复
奔跑的鞋子 2012-09-18
  • 打赏
  • 举报
回复
ps -ef|grep java
pargs 进程号
kill -9 进程号
然后再次重启就ok了!
zhjhard 2010-04-14
  • 打赏
  • 举报
回复
用"ps -ef | grep 用户名"查看进程,看是否有其它weblogic应用启动中?
TeaMo801023 2010-03-10
  • 打赏
  • 举报
回复
./myserver/ldap/ldapfiles 这个已经被其他的服务用了,你可以把ldap对应的上级目录删除,别担心,这个目录在weblogic启动时会自动添加的,然后重启,可以加我QQ:1047735733,注明CSDN,祝你好运

5,657

社区成员

发帖
与我相关
我的任务
社区描述
Web开发应用服务器相关讨论专区
社区管理员
  • 应用服务器社区
加入社区
  • 近7日
  • 近30日
  • 至今
社区公告
暂无公告

试试用AI创作助手写篇文章吧