WINCE LCD 驱动问题,启动到桌面后显示异常

dengchonglin 2011-07-19 08:32:07
最近我在更换 6410(wince 6.0) 的LCD 驱动,
原来是驱动 群创 83 的屏幕,显示一切都是好的。
现在换了 TD-T350T1G707-2 的屏,
修改了时序,以及设置。

1、在 EBOOT 的时候初始化LCD, LCD 能显示正常。
也能在LCD上显示出字母。
2、进入到 NK, 启动到最后的时候加载 LCD 驱动,
加载完 LCD 驱动后,屏幕上显示了桌面,这时候
显示还是正常的。
3、可是等到系统完全启动完成了,LCD 的显示就不正常了。
显示的字有点模糊了,LCD 的色调也不正确了,
另外,打开我的设备 LCD 还能看到桌面 WINDOWS ... 的
残影。



想了半天没想明白这是什么原因。
请教高手帮忙指点一下~!
...全文
112 点赞 收藏 14
写回复
14 条回复
切换为时间正序
当前发帖距今超过3年,不再开放新的回复
发表回复
harktrip 2011-09-07

LCD寄存器的設定不正確+被改掉

請結案給分
回复
dengchonglin 2011-09-06
哈哈,最近都没时间调试那款机器了
哎…… 事情太多了~!
非常感谢你
回复
embed_rookie 2011-09-06
呵呵 楼主,我也遇到和你类似的情况。之前有的一款屏是好的,后来过了一段时间以后公司又新买了同一样的一款屏,只是出场时间不一样而已,就出现了和你一样的情况有残影。我驱动里面初始化lcd的时候各种参数都在手册上指定的范围内,但是就是出现了那样的情况。后来我吧几个参数在手册上指定的范围内换了一下就好了。建议lz用示波器把几个信号多点点,首先看是不是在手册指定的范围内,如果是的话,就把几个参数来回的调调,可能就会没问题了。(我改的主要是 LCCR1 LCCR2 LCCR3)
回复
xiaosan5871 2011-07-20
直接上示波器吧,,,你会看到,从正常到不正常,哪个信号变了
回复
dengchonglin 2011-07-20
目前机器暂时还不能同步
回复
当我遇上-你 2011-07-20
用wince桌面助手看下,系统正常那么就是你的LCD驱动问题了
回复
dengchonglin 2011-07-20
[Quote=引用 9 楼 xiaosan5871 的回复:]

直接上示波器吧,,,你会看到,从正常到不正常,哪个信号变了
[/Quote]
恩,好方法~! 我试试看看~!
回复
xiaosan5871 2011-07-19
用同步工具CERHOST.exe看下,是不是排除系统问题?

如果显示正常,那就是你驱动问题。示波器最厉害
回复
congyue123 2011-07-19
很可能是硬件问题,两块屏的硬件特性不一样。
回复
w22net 2011-07-19
bsp是哪家提供的.
回复
xiaosan5871 2011-07-19
用同步工具CERHOST.exe看下,排除内存方面的问题~~~~~~~~~~
回复
dengchonglin 2011-07-19
应该不是硬件的问题,同一个机器用 WM 系统是好的~!
回复
当我遇上-你 2011-07-19
示波器看下时钟信号跟你屏的要求一样不?
回复
jonsenwu 2011-07-19
硬件问题的可能比较大,换个平台试试,再就是看看其他驱动有没有修改参数
回复
相关推荐
发帖
嵌入开发(WinCE)
创建于2007-09-28

1.9w+

社区成员

硬件/嵌入开发 嵌入开发(WinCE)
申请成为版主
帖子事件
创建了帖子
2011-07-19 08:32
社区公告
暂无公告