SNMP版本问题

youlongzaitian 南京普天网络有限公司 项目经理  2013-06-27 10:21:19
请教大家一个问题:
支持SNMPV3版本的设备
支持SNMPV2版本吗?
我看有些文章提到版本共存的问题~
但是如果支持V2版本的话,那V3的安全机制岂不是不会形同虚设?
拜托大家指导一下,困惑好几天了~

在线等~~
...全文
303 点赞 收藏 5
写回复
5 条回复
youlongzaitian 2013年06月27日
就是支持V3不一定支持V1V2,如果开发者采用版本共存的架构可以支持V1V2V3?
回复 点赞
oyljerry 2013年06月27日
有些会有后向兼容。可以通过控制v2能做的事情来设置安全,比如只让Get
回复 点赞
oyljerry 2013年06月27日
引用 4 楼 youlongzaitian 的回复:
我的意思就是如果支持V3,能不能保证支持V1V2?
V1不一定,V2应该都会支持吧。其实还是取决于你设备自己对于版本的控制。
回复 点赞
youlongzaitian 2013年06月27日
我的意思就是如果支持V3,能不能保证支持V1V2?
回复 点赞
shootingstars 2013年06月27日
引用 2 楼 youlongzaitian 的回复:
就是支持V3不一定支持V1V2,如果开发者采用版本共存的架构可以支持V1V2V3?
支持V3的一般都支持V1和V2吧(我没有看见什么设备仅仅支持V3) 设备支持V几可以通过选项来设置吧。
回复 点赞
发动态
发帖子
网络编程
创建于2007-09-28

7880

社区成员

6.4w+

社区内容

VC/MFC 网络编程
社区公告
暂无公告