用的是tomcat7,输入http://localhost:8080/时测试tomcat正常。当我点击上面的examples时,报错: type Status report message /examples/ description The requested resource is not available. 就这三行,倒是简单省事。不过可就郁闷我了。而且所有的项目都报错。求指点。。。。
异常已经贴出来了,就那三行!另外我配置了环境变量,还是不行。我无奈了,就给卸载了,又装了个免安装的6.0.
这个问题以后我在去找,现在又有新麻烦,我不熟项目的时候,出现这种错误:
八月 06, 2013 11:22:21 下午 org.apache.catalina.core.StandardContext filterStart
SEVERE: Exception starting filter struts2
Unable to load configuration. - bean - jar:file:/D:/workTool/apache-tomcat-6.0.37/webapps/lingyun/WEB-INF/lib/struts2-core-2.3.15.1.jar!/struts-default.xml:29:72
at org.apache.struts2.dispatcher.Dispatcher.init(Dispatcher.java:485)
at org.apache.struts2.dispatcher.ng.InitOperations.initDispatcher(InitOperations.java:74)
at org.apache.struts2.dispatcher.ng.filter.StrutsPrepareAndExecuteFilter.init(StrutsPrepareAndExecuteFilter.java:51)
at org.apache.catalina.core.ApplicationFilterConfig.getFilter(ApplicationFilterConfig.java:295)
at org.apache.catalina.core.ApplicationFilterConfig.setFilterDef(ApplicationFilterConfig.java:424)
at org.apache.catalina.core.ApplicationFilterConfig.<init>(ApplicationFilterConfig.java:115)
Caused by: Unable to load configuration. - bean - jar:file:/D:/workTool/apache-tomcat-6.0.37/webapps/lingyun/WEB-INF/lib/struts2-core-2.3.15.1.jar!/struts-default.xml:29:72
at com.opensymphony.xwork2.config.ConfigurationManager.getConfiguration(ConfigurationManager.java:70)
at org.apache.struts2.dispatcher.Dispatcher.init_PreloadConfiguration(Dispatcher.java:429)
at org.apache.struts2.dispatcher.Dispatcher.init(Dispatcher.java:473)
... 21 more
Caused by: Unable to load bean: type: class:com.opensymphony.xwork2.ObjectFactory - bean - jar:file:/D:/workTool/apache-tomcat-6.0.37/webapps/lingyun/WEB-INF/lib/struts2-core-2.3.15.1.jar!/struts-default.xml:29:72
at com.opensymphony.xwork2.config.providers.XmlConfigurationProvider.register(XmlConfigurationProvider.java:245)
at org.apache.struts2.config.StrutsXmlConfigurationProvider.register(StrutsXmlConfigurationProvider.java:102)
at com.opensymphony.xwork2.config.impl.DefaultConfiguration.reloadContainer(DefaultConfiguration.java:226)
at com.opensymphony.xwork2.config.ConfigurationManager.getConfiguration(ConfigurationManager.java:67)
... 23 more
Caused by: Bean type class com.opensymphony.xwork2.ObjectFactory with the name xwork has already been loaded by bean - jar:file:/D:/workTool/apache-tomcat-6.0.37/webapps/lingyun/WEB-INF/lib/struts2-core-2.3.12.jar!/struts-default.xml:29:72 - bean - jar:file:/D:/workTool/apache-tomcat-6.0.37/webapps/lingyun/WEB-INF/lib/struts2-core-2.3.15.1.jar!/struts-default.xml:29:72
at com.opensymphony.xwork2.config.providers.XmlConfigurationProvider.register(XmlConfigurationProvider.java:229)
... 26 more
八月 06, 2013 11:22:21 下午 org.apache.catalina.core.StandardContext start
SEVERE: Error filterStart
八月 06, 2013 11:22:21 下午 org.apache.catalina.core.StandardContext start
SEVERE: Context [/lingyun] startup failed due to previous errors
能看出是什么错误么?