HDOJ-1008大神求错

qq_23908539 2014-11-25 10:50:51
Problem Description
The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.



Input
There are multiple test cases. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100. A test case with N = 0 denotes the end of input. This test case is not to be processed.



Output
Print the total time on a single line for each test case.



Sample Input
1 2
3 2 3 1
0


Sample Output
17
41
#include <stdio.h>
int max(int n);
int min(int n);
int a[100];
int main()
{
int i,sum,up,down,n;
int s;
while (scanf("%d",&n)!=EOF&&n)
{
sum=0;
up=0;
down=0;
if(n==1)//如果只变化一层
{scanf("%d",&s);
sum=sum+s*6+5;}
else {for(i=0;i<n;i++)//如果变化不止一层
scanf("%d",&a[i]);
up=max(n)*6;
down=(max(n)-min(n))*4;
sum=sum+up+down+n*5;}
printf("%d\n",sum);
}
return 0;
}
int max (int n)
{
int i;
for(i=1;i<n;i++)
if(a[i]>a[0])
a[0]=a[i];
return a[0];
}
int min (int n)
{
int i;
for(i=1;i<n;i++)
if(a[i]<a[0])
a[0]=a[i];
return a[0];
}
我自己运行还没问题,但一在网站上提交就WA。。大神帮忙看看哪里有错误
...全文
55 1 打赏 收藏 转发到动态 举报
写回复
用AI写文章
1 条回复
切换为时间正序
请发表友善的回复…
发表回复
FancyMouse 2014-11-25
  • 打赏
  • 举报
回复
A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. 3 2 1 2

69,382

社区成员

发帖
与我相关
我的任务
社区描述
C语言相关问题讨论
社区管理员
  • C语言
  • 花神庙码农
  • 架构师李肯
加入社区
  • 近7日
  • 近30日
  • 至今
社区公告
暂无公告

试试用AI创作助手写篇文章吧