安装完idea后在配置project sdk时碰到问题 [问题点数:20分,无满意结帖,结帖人zhanghaining_tiger]

Bbs1
本版专家分:0
结帖率 100%
Bbs9
本版专家分:80005
版主
Blank
技术圈认证 用户完成年度认证,即可获得
Blank
签到王者 累计签到获取,不积跬步,无以至千里,继续坚持!
Blank
脉脉勋章 绑定脉脉第三方账户获取
Blank
铜牌 2013年8月 总版技术专家分月排行榜第三
Bbs1
本版专家分:0
Bbs1
本版专家分:0
Bbs1
本版专家分:0
【Project SDK is not defined】错误解决方案
错误分析: 首先看报错原因,错误信息显示项目SDK未定义,提示让<em>安装</em>SDK,一些新手小伙伴们这个<em>时</em>候就有点迷惑了,只知道jdk是java开发工具包,那么SDK是什么呢,我也从来没有用过这个东西呀,怎么这个<em>时</em>候就提示让我<em>安装</em>呢。这个<em>时</em>候小伙伴们不要着急,其实SDK指的是软件开发工具包(缩写:SDK、外语全称:Software Development Kit)一般都是一些软件工程师为特定的软件包...
Cannot set up a python SDK Python2.7. The SDK seems invalid.配置问题
Cannot set up a python SDK Python2.7. The SDK seems invalid. 就是如何<em>配置</em>总是会出现这种情况,也就是说没有<em>配置</em>成功。 解决办法: 然后我就参考下面的博客进行了相关<em>配置</em>。https://blog.csdn.net/qinglingLS/article/details/90444765 (讲得很详细)。 然后,我就直接关闭...
安装IntelliJ IDEA后的报project sdk is not defined错误
https://blog.csdn.net/Q1157009511/article/details/81585067
Pycharm报错解决:error:please select a valid Python interpreter
问题描述: 之前PC上<em>安装</em>的是Python2,后来工作需要转成Python3了。然后在用pycharm运行Python2的程序<em>时</em>发现源程序运行报错(出去语法错误) error:please select a valid Python interpreter 问题原因: 在pycharm导入源项目的<em>时</em>候没有选择运行Python的程序 解决办法: 1、更改Pycharm的设置打开se...
SDK不支持选定的Java版本8(最大值7)
selected Java version 8 is not supported by SDK (maximum 7) 建立项目<em>时</em>,<em>idea</em>给了一个提示 ‘SDK不支持选定的Java版本8(最大值7)’ 问题的原因在: 第一页的<em>project</em> SDK:为1.7。 而第二页的java Version 最低为8.所以会提示 ‘SDK不支持选定的Java版本8(最大值7)’ 一开始我在想 SDK是...
IntelliJ idea添加jdk
No Java SDK of appropriate version found. In addition to the IntelliJ Platform Plugin SDK, you need to define a JDK with the same Java version (JDK_1_8, description: 1.8).1.Ctrl+Shift+Alt+S—- >点击+添加jdk
Cannot set up a python SDK at Python 3.7 (detecation) (D:\Anaconda3\python.exe). The SDK seems inva
一、报错 这个问题已经不是第一次出现了,可能是前面python的版本没有装好的原因,在新建工程的<em>时</em>候总是出现这样的一个报错问题,每次稀里糊涂<em>配置</em>好了,可是总是出现然后又花大量的<em>时</em>间去回忆是不可取的,在这里系统地了解了下1该报错的问题,并作以总结。 Cannot set up a python SDK at Python 3.7 (detecation) (D:\Anaconda3\python....
idea找不到jdk怎么办
这个要怎么解决
创建maven工程之后,提示[FATAL_ERROR] Cannot start Maven: Project JDK is not specified. Configure<...
存在这种问题的原因是因为没有匹配到合适的JDK按照下面的步骤即可匹配 转载于:https://www.cnblogs.com/zlj1992/p/6128697.html
intellij IDEA软件java项目No SDK配置jdk开发,安装IDEA软件步骤
我们在使用intellij <em>idea</em>开发java项目的<em>时</em>候,我们在创建的<em>时</em>候会发现提示No SDK,影响创建和使用项目,我们需要下载和<em>配置</em>需要的JDK电脑1我们使用intellij <em>idea</em>创建java项目,如图所示的<em>时</em>候,在创建初始界面会提示No SDK,这说明软件本身并不提供开发所需的工具,我们需要自己下载,好在软件贴心,下面就有我们需要的链接,点击download jdk2点击下载链接后,我...
Idea安装Python插件并配置Python SDK
Idea<em>安装</em>Python插件并<em>配置</em>Python SDK 第一步:在help/about中查看IDEA版本,作者IDEA 15.0.2 第二步:在http://plugins.jetbrains.com/plugin/631中下载python-143.116.zip插件 第三步:windows下解压到IDEA的plugins目录,E:\Idea\plugins\python
Module 'rom' is not defined 错误的解决办法
出现Module 'rom' is not defined:解决如下:在ModelSim中执行“Compile——Complie...”,出现“Copile Source Files”对话框,然后根据自己的生成的ROM(我的是rom_sim.v文件),双击<em>安装</em>一次,之后就不会出现问。重启。
项目无法添加tomcat,如何修改项目的jdk版本,Java version 1.8 is not supported
当我们把以前的项目加到Tomcat中<em>时</em>,经常报这样的错误,因为之前我们系统上用的是JDK1.8,而现在用的是1.7. 因为JDK版本不同,导致项目无法加到Tomcat下。 图1 解决思路:将项目的JDK版本改为当前系统上的JDK版本。 解决方法: 1.打开菜单栏中 window-preference,然后找到如图的java-compiler。点击选中的蓝色字。会弹出图3
IDEA配置SDK
<em>idea</em><em>配置</em>SDK详细的不解释!
IntelliJ IDEA Project SDK 为none 解决方法
第一次在IDEA上面创建项目的<em>时</em>候,会出现这种情况 解决方案: 步骤一:在电脑上先<em>安装</em>JDK,记住路径 步骤二:File菜单---&gt;<em>project</em> structure下--&gt;Platform Settings--&gt;点击+窗口顶部的绿色。 设置成果效果图: ...
intellij idea 配置python sdk问题
在intellij <em>idea</em> 下<em>安装</em>好了python插件,但设置python <em>sdk</em>的<em>时</em>候,报错如图![图片说明](https://img-ask.csdn.net/upload/201607/13/1468399366_491898.png), 导致很多这种错误![图片说明](https://img-ask.csdn.net/upload/201607/13/1468399456_177258.png) 请问下怎么解决,能在intellij <em>idea</em>上运行python程序,谢谢! 注:不用推荐pycharm,因为我同<em>时</em>要使用java
IDEA打开后,显示Project SDK is not defined代码无法运行,如何解决?
2020年2月10日上午,在家自学Java,打开IDEA的<em>时</em>候,运行代码发现Project SDK is not defined错误,代码无法运行。搞了好久
Android Studio Please select Android SDK
问题 从Github上导入一个项目<em>时</em>,app旁边有一个红色叉,点击EditConfigurations,在最下方提示“Please select Android SDK”,但是SDK在正确的路径。 解决 同步gradle files: Tools —— Android —— Sync Project with Gradle Files ...
Android Studio 提示Please select android sdk
图文解释这个问题,遇到这个问题,只要<em>配置</em>一下module对应的<em>sdk</em>就行了。 这是出错的图片,如果是这样,再照着做就行。 第一步:打开File-&amp;gt;Project Structure… 第二步:选中,对应的Module,这里是名为demo的Module 第三步:选择SDK。 最后,点右下角的OK,等build<em>完</em>就可以跑了。 ...
IDEA:Cannot start compiler:the SDK is not specified for module...错误修复
     IDEA:Cannot start compiler:the SDK is not specified for module...错误修复   转载:https://blog.csdn.net/weixin_42158198/article/details/82118472   IDEA出现报错 解决方法: 一、在Project Structure中选择SDKs,点击右侧的...
运行pythonp 提示:please select a valid interpreter
运行pythonp 提示:please select a valid interpreter
Android studio 导入项目报错 project sdk is not defined
1.  是否选择项目所在目录,不能选择外层父目录 2. 选择一个SDK
IDEA 创建 SpringBoot 遇到的一些问题
创建一个SpringBoot项目 Pom.xml <em>配置</em> &amp;lt;?xml version=&quot;1.0&quot; encoding=&quot;UTF-8&quot;?&amp;gt; &amp;lt;<em>project</em> xmlns=&quot;http://maven.apache.org/POM/4.0.0&quot; xmlns:xsi=&quot;http://www.w3.org/2001/XMLSchema-instance&quot; xsi:sch...
Android Studio在运行显示Please Select Android SDK的解决方法
1 问题提出 在Android Studio中点击“Run”按键,程序没有正常运行,而是弹出“Edit configuration”对话框,在对话框底部的错误信息中,显示“Please Select Android SDK”,如图1所示。   图1 显示错误信息 2 问题分析 出现该问题的主要原因是Android Studio程序之前异常关闭,导致<em>配置</em>文件损坏,需要在线更新SDK才能...
IntelliJ IDEA 或Android Studio中提示:Project SDK is not defined
之前用Android Studio去打开一个项目后,结果遇到提示: Project SDK is not defined 如图: 【解决过程】 1.试着去点击Setup SDK,出现设置对话框: 然后就卡死了好一会。 然后就好了,就没了这个提示了。 【总结】 好像是Android Studio对于刚使用的<em>时</em>候,没有确定Android的SDK,所以需要去设置一
AnnotationTransactionAttributeSource is only available on Java 1.5 and higher
在JBOSS7下热部署war包出错,我用的是<em>idea</em>开发工具,org.springframework:spring:2.0.8,和Jdk1.8。 网上各种搜索,原来因为spring core org.springframework.core.JdkVersion.java不支持Jdk1.8。支持的Jdk版本分别为1.3(default),1.4, 1.5, 1.6 and 1.7,如果检测到
打开2016.1.3版的IntelliJ IDEA,出现问题
刚下载了新版的IntelliJ IDEA ,一打开就出现Cannot start internal HTTP server. Git integration, JavaScript debugger and LiveEdit may operate with errors. Please check your firewall settings and restart IntelliJ IDEA![图片说明](https://img-ask.csdn.net/upload/201606/14/1465879313_531867.png)这样的红色警告字,用浏览器预览写好的页面显示无法访问!![图片说明](https://img-ask.csdn.net/upload/201606/14/1465879451_410948.png),是什么原因呢,如何解决
Pycharm 项目运行错误问题整理
以下错误发生在拷了别的项目在自己电脑上运行的出错信息: 一、ImportError: No module named matplotlib.pyplot 意思缺少 matplotlib库, 可以点击Python -&gt; preference -&gt; Project Interpreter 下面的箭头是添加缺少的第三方库 上...
Pycharm中python项目迁移出现虚拟环境的sdk不可用
自己从笔记本迁移一个Flask项目的台式机之后,在Pycharm上设置虚拟环境一直提示<em>sdk</em>不可用,大概内容如下: cannot set up a python <em>sdk</em> at python 2.7 permission denied 整个项目迁移过来的<em>时</em>候把原来的虚拟环境也直接带过来了,导入到Pycharm想着就可以直接设置<em>完</em>使用。但是这个问题一直出现,后面也找不到解决办法,最后面是重新在本机创...
解决AnnotationTransactionAttributeSource is only available on Java 1.5 and highe
由于项目需要把jdk升级成为了jdk8,在eclipse中导入一个jdk1.6的项目,启动tomcat的<em>时</em>候,报错: AnnotationTransactionAttributeSource is only available on Java 1.5 and highe 想要解决这个错误,一般有两种办法:1、将jdk8换成jdk7,重新启动项目就好了(由于另一个项目必须是jdk1.8,所以降版...
IDEA Cannot start compiler the SDK specified for module
、   1.<em>配置</em>JDK。我的电脑里已经下载好了,我在这里就不在赘述 在IDEA的菜单栏中选中File 选中Project Structure 然后,弹出来的对话框左边有一个SDKs单击它 在中间的一栏中有个+号单击它,一单击会出现Add New SDK然后选中第一个JDK; 然后定位到你JDK<em>安装</em>到那个路径下了,比如我的在:C:\Program Files\Java\jdk1.8.0...
error:java :jdk isnot specified module 'xxx'
出现上述问题是,因为jdk没有<em>配置</em> <em>配置</em>后即可
hello world:The SDK layoutlib version is not supported 请大神帮忙看下
我晕..刚开始这么多问题.. 最开始是avd无法启动,自己找了找,想办法 <em>安装</em>了haxm,可以起来了. 然后创建 helloworld,版本实在是多,安了三个吧,api22,api26(最新的),和一
idea创建springboot项目出现的问题
当启动一个不连接数据库的springboot<em>时</em>,会报错Cannot determine embedded database driver class for database type NONE 是因为springboot在启动<em>时</em>,会扫描DataSource相关<em>配置</em>的包所以 @SpringBootApplication(exclude = {DataSourceAutoConfiguratio
idea中创建的go项目,添加project sdk没有go sdk选项的解决方式。
2019独角兽企业重金招聘Python工程师标准&gt;&gt;&gt; ...
IntelliJ IDEA 2017 创建SpringBoot项目, 及.jar没有主清单属性解决办法
1. 创建项目: File &gt;&gt; New &gt;&gt; Spring Initializr 选好 SDK, 及 依赖包(比如 Web &gt;&gt; Web ) . 需要使用 kotlin的, 注意选择语言. 2. 如果提示连接数据库方面的问题, 可以暂<em>时</em>用这个<em>配置</em>处理一下 @EnableAutoConfiguration(exclude= arrayOf(DataSo...
Error: module "pages/data/data.js" is not defined [已解决]
微信小程序Error: module “pages/data/data.js” is not defined问题求助。 在微信开发者工具中,分包操作都还是可行的。数据也都能读出来, 不是文件路径错误。 如下: 读取出来数据显示的结果: 读取js数据路径: data.js中的代码块: Page({ data: { }, }) var local_database = [{ "nam...
记录一下please select sdk异常
前几天打开项目发现一个异常,显示无法找到<em>sdk</em>,查过一些资料但是都没有起作用,最后发现是compileSdkVersion没有在<em>配置</em>文件中,添加上就ok了(虽然不知道为什么会突然没了)记录一下!第一篇blog...
新建项目的候,选项里没有我安装sdk,请问咋回事呢?谢谢
win7系统,装的vs2008,<em>安装</em>了一个<em>sdk</em> ,用于wince程序开发的,新建项目的<em>时</em>候选的 智能设备-win32 智能设备项目,可以选平台的<em>时</em>候,没有我已<em>安装</em>好的<em>sdk</em>,请问咋回事,怎么找原因?
小程序 :thirdScriptError sdk uncaught third Error或module "app.js" is not defined
小程序出现这种情况: 这种情况: 还有这种: 不要慌,只要这小程序详情里勾选es6转es5就好了
IDEA出现[FATAL_ERROR] Cannot start Maven: Project JDK is not specified. 的解决办法
参考:http://www.tonitech.com/2404.html 转载于:https://www.cnblogs.com/sakura-sakura/p/7137353.html
pycharm中出现name 'reponse' is not defined错误怎么解决,请教大神,急????
pycharm中在setting中<em>安装</em>了pesponse库还是出现name 'reponse' is not defined错误应该怎么办,请教大神!!!!
sdk" is not defined">module "pages/index/wx-server-sdk" is not defined
1、错误描述 VM542:1 thirdScriptError module "pages/index/wx-server-<em>sdk</em>" is not defined; [Component] Event Handler Error @ pages/index/index#bound submitData Error: module "pages/index/wx-server-<em>sdk</em>" is n...
导入项目常见的Android Studio编译出现please select Android SDk
导入项目的<em>时</em>候 编译没有通过 app显示小红叉 点击上面的小三角 Edit Configurations 进入Please select Android SDK 检查一下 local.properties 看看里面是否<em>配置</em>了SDK 在App 里面的app.iml里面在看一下是否<em>配置</em>了 &lt;orderEntry type="jdk" jdkName="Android API 27 Plat...
IntelliJ IDEA 不能识别java.util。或者说找不到,求助
如图,关于java.util的类居然无法识别,比如Date,已经设置了jdk:
idea 安装python插件,指定python sdk
1.<em>idea</em>打开 如图,setting-&amp;gt;plugins-&amp;gt;搜索python-&amp;gt;install-&amp;gt;重启<em>idea</em>     2.创建python项目pythona模块,指定<em>sdk</em><em>安装</em>目录,<em>idea</em>上 python 的hello world (1)创建python项目 (2)创建python模块   (3)指定<em>sdk</em> 选择自己的python.exe就...
解决Project facet Java version 11 is not supported.问题
出现该提示说明项目是其他版本jdk编译的,在eclipse里运行<em>时</em>会报版本不支持。 解决方法:首先查看本机电脑的jdk版本(cmd→Java -version),然后选中项目Properties ,选择Project Facets,右击选择Java, Change Version ,选择本机电脑的jdk版本即可,最后点击apply退出。 ...
windows中不同版本JDK环境的切换(以JDK1.7和JDK1.8为例)
JDK1.9已出了很长<em>时</em>间了,很多大佬的Windows的JDK基本都是JDK1.8左右,废话不多说,下面进入正题。步骤: 1.PC本机已<em>安装</em>JDK1.7(或JDK1.8),下载<em>安装</em>另一个JDK1.8(或JDK1.7)。2.博主一直用的JDK1.8,由于课程需要,下载JDK1.7,这里CLASSPATH和PATH的变量值都引用JAVA_HOME的变量值,故要切换JDK1.7的环境只需要修改JAVA
Python2.7+SqlMap
使用sqlmap首先必须的<em>安装</em>python2.7的环境,高于这个版本则不能<em>安装</em>,博主已经曾经浪费了一晚上验证了这个事实,还有一个sqlmap使用非常方便,如果想咨询web渗透的可以进我的网站www.i
运行python文件报错:please select a valid interpreter
运行python文件报错:please select a valid interpreter。这是因为没有选择interpreter。解决方法如下:打开python的setting(Ctrl+Alt+S)搜索“interpreter”,右侧<em>project</em> interpreter 中选择一个,我选择的是show all。点击OK。...
Please select Android SDK的解决
  刚才还编译通过,能运行的工程,现在点运行就弹出一个对话框,报错:   ERROR: Please select Android SDK。     嗯?   File-&amp;gt;Project Structure中将Build tools version改成别的。   编译,通过。再点运行,还是不行。输出中提示&quot;Update&quot;,于是点了,又变回原来的,编译了可以了。     据此现象...
Intellij IDEA配置AndroidSDK报错,No Java SDK of appropriate version found.
我明明<em>配置</em>了jdk1.7的,<em>配置</em>AndroidSDK<em>时</em>报错 换了jdk1.8就行了
什么是SDK?
    经常会在技术论坛里面看到类似这样的帖子:“什么是 SDK?”,“请高手讲一下 SDK 是什么东东?”……    其实很简单,SDK 就是 Software Development Kit 的缩写,中文意思就是“软件开发工具包”。这是一个覆盖面相当广泛的名词,可以这么说:辅助开发某一类软件的相关文档、范例和工具的集合都可以叫做“SDK”。具体到我们这个系列教程,我们后面只讨论广义 SDK
idea-设置SDK
设置<em>sdk</em>1.file-&amp;gt;<em>project</em> structure2.<em>project</em>-&amp;gt;<em>project</em> <em>sdk</em>-&amp;gt;new设置maven<em>配置</em> 1.file-&amp;gt;setting2.搜索-&amp;gt;maven全局settingfile-&amp;gt;other setting-&amp;gt;default setting设置编译版本在pom.xml中<em>配置</em>插件 java-compiler    ...
当运行pychrm遇到please select a valid interpreter怎么解决
运行python文件出现,报错please select a valid interpreter 这是因为没有选择interpreter 解决方法如下 更改Pycharm的设置 打开settings(CTRL + ALT + S) 查找框输入interpreter 选择一个Project Interpreter <em>完</em>成 ...
首次使用Pycharm出现please select a valid Python interpreter问题的解决方法
今天想尝试下PyCharm就下了最新的2019版本,<em>安装</em>后没法运行以前自己通过PyIDE写的文件报的都是please select a valid Python interpreter的提示,我想应该是我先装了Python后装PyCharm的原因导致设置环境变量是出了问题。导致运行是没法找到有效的解释器。我看其他大佬的解决办法都是在File的Project:当前尝试的文件.py中设置Project...
Mac下左侧project不显示,或者project中的目录结构不显示
手贱的不知道点了哪一下,就找不到左侧的目录结构了,度娘上的经验打开左侧的<em>project</em>,但是原本的目录层次不显示,只是展示了几个扩展的目录 要<em>完</em>美的解决该问题很简单,只需关闭项目,关闭<em>idea</em> ,然后打开file---<em>project</em> structure--modules----import module;我的问题就这样解决了
Project facet Java version 1.8 is not supported解决记录
一看知道是因为jdk版本不一致所导致,如何解决?方法一:选中项目 Properties , 选择 Project Facets,右击选择 Java , Change Version 方法二:在 项目的目录下有一个.settings的文件夹,该文件夹下有一个org.eclipse.wst.common.<em>project</em>.facet.core.xml文件,内容如下;
Project facet Java version 1.8 is not supported解决方案
1.由于新的项目需要,随即<em>安装</em>了jdk1.8;首先计算机<em>安装</em>了32位d jdk1.7,后来<em>安装</em>了32位jdk1.8 , 修改了下面两处地方后, (1) (2) 后来通过点下图的内容,仍然报错【此处是我更改之后有模拟的故没有报错】 解决方案: 点eclipse中的内容windows-&amp;gt;service,弹出如下内容: 而后点击如下操作既可: ...
Error:java:JDK isn't specified for module
今天用<em>idea</em>编写程序过程中,电脑出现问题,显示电脑重启。结果问题就出来了。 首先是打开项目: 1、<em>idea</em>里面的<em>project</em>下面只有两个东西。Power_manager.iml和External Libraries两个东西而且下面显示Error:java:JDK isn't specified for module。(我的项目名:Power_manager) 我还不信邪,打开其他的项目,
are only available on JDK 1.5 and higher 错误
org.springframework.beans.factory.BeanDefinitionStoreException: Unexpected exception parsing XML document from class path resource [applicationContext.xml]; nested exception is java.lang.IllegalState...
idea jdk明明是1.8了,还是 出现Diamond types are not supported at this language level
共有三个地方: <em>project</em> structure中的<em>project</em> ,SDK选择1.8,Project language level选择8 <em>project</em> structure中的module,选择Language level为8 setting中的java compiler
Project facet Java version 1.8 is not supported解决方法
方法一: 右击项目 选择Properties , 再选择 Project Facets,右击选择 Java ,修改Version 方法二: 在该项目的目录下有一个.settings的文件夹,文件夹下有一个org.eclipse.wst.common.<em>project</em>.facet.core.xml文件,内容如下; &amp;lt;?xml version=&quot;1.0&quot; encoding=&quot;UTF-8...
Project facet Java version 1.8 is not supported 解决方法
问题:jdk版本不一致所导致 方法一: 选中项目 Properties , 选择 Project Facets,右击选择 Java , Change Version  方法二: 使用快捷键 command+shift+R,输入*.<em>project</em>*facet,找到.settings的文件夹,该文件夹下有一个org.eclipse.wst.common.<em>project</em>.facet.core.x...
eclipse的activity_main.xml出现The SDK layoutlib version is not supported
我的模拟机也打不开 是不是和这个有关系?
Selected Cylinder exceeds maximum supported by BIOS
grub无法启动linux,改了以后老报error,改咋解决呢?
IntelliJ IDEA导入JDK出现The selected directory is not a valid home for JDK问题的解决方法
昨天在实验室的台式机上<em>配置</em>java。之前一直在MAC上都是使用IntelliJ IDEA玩耍,这次也不能少了它。马上上官网下载了一个Windows版的,用学生账号注册<em>完</em>之后,就可以直接进行使用了!但是在导入JDK的<em>时</em>候却遇到了问题,下图是添加JDK的界面:     点击new按钮后出现下图:    点击JDK后出现了这个框框:     你要是随便选一个文件夹的话就会弹出下图的对话
eclipse sdk版本过高导致问题
最近手贱把eclipse里的<em>sdk</em> tools更新到了22.6.3,但是在新建安卓工程<em>时</em>出现了好多问题,第一,新建的工程继承ActionBarActivity,而且工程也面目全非,好不习惯,最可气的是
IntelliJ IDEA 中如何配置JDK
IDEA不会自动匹配系统的JDK环境。如果在IDEA里面没有<em>配置</em>JDK,那么运行程序<em>时</em>就会报错 找不到你的JDK。接下来就开始<em>配置</em>JDK,IDEA里面可以同<em>时</em>有多个版本的JDK,并且需要开发者手动<em>配置</em>项
IntelliJ IDEA 基本配置入门
今天下载<em>安装</em>IntelliJ IDEA,随手创建了一个项目,执行Build提示错误。与大多数用于开发JAVA的IDE类似,不做任何<em>配置</em>,编译是不会成功的。因此我尝试对IDEA的<em>配置</em>进行了一点初步探索,顺手记下供同行参考。
IntelliJ IDEA 项目相关的几个重要概念介绍
IntelliJ IDEA 项目相关的几个重要概念介绍 发布于 2015-09-23 23:02:48 | 11 次阅读 | 评论: 0 | 来源: 网络整理 本篇内容为大家提供的是IntelliJ IDEA 使用教程中的IntelliJ IDEA 项目相关的几个重要概念介绍,IntelliJ IDEA是java语言开发的集成环境,IntelliJ在业界被公认为最好的jav
关于 AnnotationConfigBeanDefinitionParser are only available on JDK 1.5 and higher
最近再学习SPRING,今天就自己想<em>配置</em>起来玩一玩,结果当使用注解
项目运行出错,求解决方法!!!
刚从SVN下了个项目,可是在Eclipse里面,用tomcat跑<em>时</em>,就报出下面的错误了,在网上找过各种方法,可是都不行,请各位路过的大大,有空帮忙看看这是个什么情况,错在什么地方了,给个解决办法,谢谢!!! ``` 2017-05-15 11:10:15,522 ERROR [org.springframework.web.context.ContextLoader] - Context initialization failed org.springframework.beans.factory.BeanDefinitionStoreException: Unexpected exception parsing XML document from class path resource [applicationContext-service.xml]; nested exception is java.lang.IllegalStateException: AnnotationTransactionAttributeSource is only available on Java 1.5 and higher at org.springframework.beans.factory.xml.XmlBeanDefinitionReader.doLoadBeanDefinitions(XmlBeanDefinitionReader.java:420) at org.springframework.beans.factory.xml.XmlBeanDefinitionReader.loadBeanDefinitions(XmlBeanDefinitionReader.java:342) at org.springframework.beans.factory.xml.XmlBeanDefinitionReader.loadBeanDefinitions(XmlBeanDefinitionReader.java:310) at org.springframework.beans.factory.support.AbstractBeanDefinitionReader.loadBeanDefinitions(AbstractBeanDefinitionReader.java:143) at org.springframework.beans.factory.support.AbstractBeanDefinitionReader.loadBeanDefinitions(AbstractBeanDefinitionReader.java:178) at org.springframework.beans.factory.support.AbstractBeanDefinitionReader.loadBeanDefinitions(AbstractBeanDefinitionReader.java:149) at org.springframework.web.context.support.XmlWebApplicationContext.loadBeanDefinitions(XmlWebApplicationContext.java:124) at org.springframework.web.context.support.XmlWebApplicationContext.loadBeanDefinitions(XmlWebApplicationContext.java:92) at org.springframework.context.support.AbstractRefreshableApplicationContext.refreshBeanFactory(AbstractRefreshableApplicationContext.java:123) at org.springframework.context.support.AbstractApplicationContext.obtainFreshBeanFactory(AbstractApplicationContext.java:422) at org.springframework.context.support.AbstractApplicationContext.refresh(AbstractApplicationContext.java:352) at org.springframework.web.context.ContextLoader.createWebApplicationContext(ContextLoader.java:255) at org.springframework.web.context.ContextLoader.initWebApplicationContext(ContextLoader.java:199) at org.springframework.web.context.ContextLoaderListener.contextInitialized(ContextLoaderListener.java:45) at org.apache.catalina.core.StandardContext.listenerStart(StandardContext.java:4276) at org.apache.catalina.core.StandardContext.start(StandardContext.java:4779) at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1061) at org.apache.catalina.core.StandardHost.start(StandardHost.java:822) at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1061) at org.apache.catalina.core.StandardEngine.start(StandardEngine.java:463) at org.apache.catalina.core.StandardService.start(StandardService.java:525) at org.apache.catalina.core.StandardServer.start(StandardServer.java:761) at org.apache.catalina.startup.Catalina.start(Catalina.java:595) at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) at java.lang.reflect.Method.invoke(Method.java:483) at org.apache.catalina.startup.Bootstrap.start(Bootstrap.java:289) at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:414) Caused by: java.lang.IllegalStateException: AnnotationTransactionAttributeSource is only available on Java 1.5 and higher at org.springframework.transaction.config.TxNamespaceUtils.getAnnotationTransactionAttributeSourceClass(TxNamespaceUtils.java:43) at org.springframework.transaction.config.AnnotationDrivenBeanDefinitionParser$AopAutoProxyConfigurer.configureAutoProxyCreator(AnnotationDrivenBeanDefinitionParser.java:115) at org.springframework.transaction.config.AnnotationDrivenBeanDefinitionParser.parse(AnnotationDrivenBeanDefinitionParser.java:80) at org.springframework.beans.factory.xml.NamespaceHandlerSupport.parse(NamespaceHandlerSupport.java:69) at org.springframework.beans.factory.xml.BeanDefinitionParserDelegate.parseCustomElement(BeanDefinitionParserDelegate.java:1297) at org.springframework.beans.factory.xml.BeanDefinitionParserDelegate.parseCustomElement(BeanDefinitionParserDelegate.java:1287) at org.springframework.beans.factory.xml.DefaultBeanDefinitionDocumentReader.parseBeanDefinitions(DefaultBeanDefinitionDocumentReader.java:135) at org.springframework.beans.factory.xml.DefaultBeanDefinitionDocumentReader.registerBeanDefinitions(DefaultBeanDefinitionDocumentReader.java:92) at org.springframework.beans.factory.xml.XmlBeanDefinitionReader.registerBeanDefinitions(XmlBeanDefinitionReader.java:507) at org.springframework.beans.factory.xml.XmlBeanDefinitionReader.doLoadBeanDefinitions(XmlBeanDefinitionReader.java:398) ... 28 more 五月 15, 2017 11:10:15 上午 org.apache.catalina.core.StandardContext listenerStart 严重: Exception sending context initialized event to listener instance of class org.springframework.web.context.ContextLoaderListener org.springframework.beans.factory.BeanDefinitionStoreException: Unexpected exception parsing XML document from class path resource [applicationContext-service.xml]; nested exception is java.lang.IllegalStateException: AnnotationTransactionAttributeSource is only available on Java 1.5 and higher at org.springframework.beans.factory.xml.XmlBeanDefinitionReader.doLoadBeanDefinitions(XmlBeanDefinitionReader.java:420) at org.springframework.beans.factory.xml.XmlBeanDefinitionReader.loadBeanDefinitions(XmlBeanDefinitionReader.java:342) at org.springframework.beans.factory.xml.XmlBeanDefinitionReader.loadBeanDefinitions(XmlBeanDefinitionReader.java:310) at org.springframework.beans.factory.support.AbstractBeanDefinitionReader.loadBeanDefinitions(AbstractBeanDefinitionReader.java:143) at org.springframework.beans.factory.support.AbstractBeanDefinitionReader.loadBeanDefinitions(AbstractBeanDefinitionReader.java:178) at org.springframework.beans.factory.support.AbstractBeanDefinitionReader.loadBeanDefinitions(AbstractBeanDefinitionReader.java:149) at org.springframework.web.context.support.XmlWebApplicationContext.loadBeanDefinitions(XmlWebApplicationContext.java:124) at org.springframework.web.context.support.XmlWebApplicationContext.loadBeanDefinitions(XmlWebApplicationContext.java:92) at org.springframework.context.support.AbstractRefreshableApplicationContext.refreshBeanFactory(AbstractRefreshableApplicationContext.java:123) at org.springframework.context.support.AbstractApplicationContext.obtainFreshBeanFactory(AbstractApplicationContext.java:422) at org.springframework.context.support.AbstractApplicationContext.refresh(AbstractApplicationContext.java:352) at org.springframework.web.context.ContextLoader.createWebApplicationContext(ContextLoader.java:255) at org.springframework.web.context.ContextLoader.initWebApplicationContext(ContextLoader.java:199) at org.springframework.web.context.ContextLoaderListener.contextInitialized(ContextLoaderListener.java:45) at org.apache.catalina.core.StandardContext.listenerStart(StandardContext.java:4276) at org.apache.catalina.core.StandardContext.start(StandardContext.java:4779) at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1061) at org.apache.catalina.core.StandardHost.start(StandardHost.java:822) at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1061) at org.apache.catalina.core.StandardEngine.start(StandardEngine.java:463) at org.apache.catalina.core.StandardService.start(StandardService.java:525) at org.apache.catalina.core.StandardServer.start(StandardServer.java:761) at org.apache.catalina.startup.Catalina.start(Catalina.java:595) at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) at java.lang.reflect.Method.invoke(Method.java:483) at org.apache.catalina.startup.Bootstrap.start(Bootstrap.java:289) at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:414) Caused by: java.lang.IllegalStateException: AnnotationTransactionAttributeSource is only available on Java 1.5 and higher at org.springframework.transaction.config.TxNamespaceUtils.getAnnotationTransactionAttributeSourceClass(TxNamespaceUtils.java:43) at org.springframework.transaction.config.AnnotationDrivenBeanDefinitionParser$AopAutoProxyConfigurer.configureAutoProxyCreator(AnnotationDrivenBeanDefinitionParser.java:115) at org.springframework.transaction.config.AnnotationDrivenBeanDefinitionParser.parse(AnnotationDrivenBeanDefinitionParser.java:80) at org.springframework.beans.factory.xml.NamespaceHandlerSupport.parse(NamespaceHandlerSupport.java:69) at org.springframework.beans.factory.xml.BeanDefinitionParserDelegate.parseCustomElement(BeanDefinitionParserDelegate.java:1297) at org.springframework.beans.factory.xml.BeanDefinitionParserDelegate.parseCustomElement(BeanDefinitionParserDelegate.java:1287) at org.springframework.beans.factory.xml.DefaultBeanDefinitionDocumentReader.parseBeanDefinitions(DefaultBeanDefinitionDocumentReader.java:135) at org.springframework.beans.factory.xml.DefaultBeanDefinitionDocumentReader.registerBeanDefinitions(DefaultBeanDefinitionDocumentReader.java:92) at org.springframework.beans.factory.xml.XmlBeanDefinitionReader.registerBeanDefinitions(XmlBeanDefinitionReader.java:507) at org.springframework.beans.factory.xml.XmlBeanDefinitionReader.doLoadBeanDefinitions(XmlBeanDefinitionReader.java:398) ... 28 more ```
WEB项目启动报错 is only available on Java 1.5 and higher
严重: Error listenerStart 2017-04-30 23:43:34,995 ERROR - org.springfr
AnnotationAwareAspectJAutoProxyCreator is only available on Java 1.5 and higher
今下午在用spring来启动单元测试老是报这个异常,利用程序在来跑了一下查看系统中使用的jdk和jre,发现输出一切正常,jdk是1.8,jre也是1.8,检测程序如下: import java.util.Iterator; import java.util.Map.Entry; import java.util.Properties; public class TestMain{
AnnotationTransactionAttributeSource is only available on Java 1.5 and highe
是否使用了SPRING? spring版本较低?SPRING2.5版本可能不支持1.8的jdk,可能新版本有修复吧,总而言之就是1.8的JDK太高了,SPRING支持不了
tomcat启动报are only available on JDK 1.5 and higher错误
因为jdk升级成为了jdk8,但是spring的jar包版本比较低,并没有兼容到jdk8,所以才造成了现在的这个错误。 想要解决这个错误,一般有两种办法: 1、将jdk8换成jdk7,重新启动项目就好了。 2、第二种手动修改spring的jar包,在org.springframework.core目录下,有一个JdkVersion.class,自己参照包路径,重新写一个JdkVersi...
Context namespace element 'annotation-config' and its parser class [org.springframework.context.anno...
严重: Exception sending context initialized event to listener instance of class org.springframework.web.context.ContextLoaderListenerorg.springframework.beans.factory.BeanDefinitionStoreException: Unexp...
Java入门到精通——调错篇之Spring2.5使用AOP报错only available on JDK 1.5 and higher
一、问题描述及原因。 在Spring2.5Aop例子中的<em>时</em>候会出现一个错误only available on JDK 1.5 and higher,大概意思就是需要JDK1.5甚至更高版本。但是我用的是JDK1.8是比1.5高啊但是为什么报错呢?通过查阅资料此链接:http://fanli7.net/a/JAVAbiancheng/Spring/20140321/481...
IntelliJ IDEA 左边project目录设置问题
如题,<em>idea</em>每次写代码的<em>时</em>候将它收起,像这样: 点击<em>project</em>展开之后它就默认折叠到只能看到根目录了,像这样: 希望点击<em>project</em>之后他能展开之前打开过的目录,像这样展开: 有谁知道这个怎么
Android Studio 导入项目遇到sdk location not found错误,如何解决
Android Studio 导入项目<em>时</em>遇到<em>sdk</em> location not found错误,如何解决? 通常遇到这个错误之后,系统会给出这个具体详情: Gradle sync failed: SDK location not found. Define location with <em>sdk</em>.dir in the local.properties file or with an ANDROID_
idea移植project后报错
<em>idea</em>
使用IntelliJ IDEA 12.0.4不能建立android工程
在new <em>project</em>中的<em>project</em> SDK里是空的,我点new后选择androidSDK的目录,提示No JavaSDK of appropriate version found. In ad
IntelliJ IDEA 配置JDK
IDEA 是最好用的JAVA IDE,之前用的eclipse,后面在mac电脑上<em>安装</em>了IDEA 发现很好用,尤其是代码助手和debug的<em>时</em>候太方便了。于是在windows系统也装了一个,但是好像需要自己<em>配置</em>SDK(之前在mac 上装的<em>时</em>候好像没有出现这个问题),在网上找了教程,但是好像都没有解决,最后自己尝试着用命令行找到jdk的<em>安装</em>位置,然后在<em>idea</em>里面<em>配置</em>过去就行了。问题:IDEA导入JDK<em>时</em>
No JDK found. Please validate either IDEA_JDK, JDK_HOME or JAVA_HOME environment variable……问题的解决
在<em>安装</em>了Ubuntu系统后,搭建JavaEE开发环境<em>时</em>,发现用命令行打开Intellij <em>idea</em> 或者 eclipse报错,说我没有设这JDK的环境变量,可是我确实已经设置了。当然如果你是因为没有设置JDK环境变量才报这个错误,最后我会给出JDK环境变量<em>配置</em>方法。 报错图: 不知有没有注意,在这里我是用root用户(#)运行的,如果我换成普通用户运行($),就能够成功运行了。个人认为,是
IntelliJ IDEA2017.3配置java SDK
java jre 并没有和IDEA一起<em>安装</em>,所以要<em>配置</em>。否则会报错。 Cannot start compiler:the SDK is not specified for the model "**".Specify the SDK at Project Structure dialog. 解决方案:在Project Structure中<em>配置</em>SDKs,然后在Modules中设置Modul
[IDEA]IntelliJ IDEA导入JDK出现The selected directory is not a valid home for JDK问题的解决方法
昨天在实验室的台式机上<em>配置</em>Java。之前一直在MAC上都是使用IntelliJ IDEA玩耍,这次也不能少了它。马上上官网下载了一个Windows版的,用学生帐号注册<em>完</em>之后,就可以直接使用了!但是在导入JDK的<em>时</em>候遇到了问题 ,下图是添加JDK的界面: 点击new按钮后出现下图: 点击JDK后出现了这个框框: 你要是随便选一个文件夹的话就会弹出下图的对话框报错: 这句话提示...
手动下载的gradle-2.14.1-all.zip应该放在哪个目录
网络不好,手动下载的gradle-2.14.1-all.zip应该放在哪个目录才能编译通过呢? 求指教 。 最好能详细说一下原因 。
请教大家,我的Android Studio在Gradle进行Sync出现了问题,该怎么解决呢?
org.gradle.internal.resource.transport.http.HttpRequestException: Could not GET 'https://dl.google.
终于明白阿里百度这样的大公司,为什么面试经常拿ThreadLocal考验求职者了
点击上面↑「爱开发」关注我们每晚10点,捕获技术思考和创业资源洞察什么是ThreadLocalThreadLocal是一个本地线程副本变量工具类,各个线程都拥有一份线程私有的数
proe的免安装版本下载
此作平是一个机械人员变得一个插补程序 有两种插补方法分别可供选择 此外这是vb下的一个洁净 相关下载链接:[url=//download.csdn.net/download/pqlamz1235/3257883?utm_source=bbsseo]//download.csdn.net/download/pqlamz1235/3257883?utm_source=bbsseo[/url]
Nios II完成最小硬件开发过程实验报告下载
Nios II完成最小硬件开发过程,介绍了开发的整个流程,其中有源代码 相关下载链接:[url=//download.csdn.net/download/ranjianyang/4044604?utm_source=bbsseo]//download.csdn.net/download/ranjianyang/4044604?utm_source=bbsseo[/url]
51单片机总结下载
51单片机总结资料,包含定时器使用,中断使用,步进电机,LCD1602,E2PROM,ADC,DAC,实时时钟DS1302,DS18B20等资料,包含C代码。 相关下载链接:[url=//download.csdn.net/download/tyh145/10549767?utm_source=bbsseo]//download.csdn.net/download/tyh145/10549767?utm_source=bbsseo[/url]
相关热词 c# 识别回车 c#生成条形码ean13 c#子控制器调用父控制器 c# 写大文件 c# 浏览pdf c#获取桌面图标的句柄 c# list反射 c# 句柄 进程 c# 倒计时 线程 c# 窗体背景色
我们是很有底线的