dev可以运行,oj却过不去。求助大佬!!!

万年一渣渣 2018-04-14 04:54:17
have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.



Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.



Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.



Sample Input
2
1 2
112233445566778899 998877665544332211


Sample Output
Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110

代码:
#include <stdio.h>
int main()
{
long long a,b;
int i,T,x[99999][2];
scanf("%d",&T);
for(i=1;i<=T;i++)
{
scanf("%lld%lld",&a,&b);
x[i-1][1]=a;
x[i-1][2]=b;
}
for(i=1;i<=T&&a!=EOF&&b!=EOF;i++)
printf("Case:%d\n%lld + %lld = %lld\n\n",i,x[i-1][1],x[i-1][2],x[i-1][1]+x[i-1][2]);
return 0;
}
...全文
1185 3 打赏 收藏 转发到动态 举报
写回复
用AI写文章
3 条回复
切换为时间正序
请发表友善的回复…
发表回复
Fantastic~ 2018-12-04
  • 打赏
  • 举报
回复
杭电第三题,我不知道我为啥也过不了
万年一渣渣 2018-08-23
  • 打赏
  • 举报
回复
这是大数相加,long long是存不下的,需要用字符串接收,然后转化为数字相加
真相重于对错 2018-04-14
  • 打赏
  • 举报
回复
Notice that the integers are very large, that means you should not process them by using 32-bit integer. 虽然我的英语很烂,也看懂人家要求你不能用32为整形来处理这个问题 提示,用字符串

69,373

社区成员

发帖
与我相关
我的任务
社区描述
C语言相关问题讨论
社区管理员
  • C语言
  • 花神庙码农
  • 架构师李肯
加入社区
  • 近7日
  • 近30日
  • 至今
社区公告
暂无公告

试试用AI创作助手写篇文章吧