Adobe产品(Illustrator)的插件为什么不能正确加载?

hproof 2004-03-24 10:24:53
我已经下载了 Illustrator SDK,除了代码外,还包括一些pdf文档如教程和文件格式。
文档中指出该SDK适用于 Illustrator 9.0,我安装的是8.0。已经看了大约1个星期。

教程太简略了,即使编译示例代码也无法正确运行(在软件中找不到相关的新功能),只能在帮助菜单中找到插件名列表。

我觉得可能是没有正确表明插件的类型,并且在系统装载时没有建立相关菜单的缘故。但不明白为什么示例代码也无法工作。

文档里说当PIPL资源中没有定义impt和expt属性时,系统将询问属性。但我的资源采用SDK自带的(win目录下一个bin文件),它并没有empt/expt属性,结果启动时也没有收到期待的询问消息。

由于刚接触这种非win32的异类(它使用类似COM的技术,却不是COM),现在停滞不前了。特此询问国内相关的技术论坛,以解决这些问题
...全文
168 2 打赏 收藏 举报
写回复
2 条回复
切换为时间正序
当前发帖距今超过3年,不再开放新的回复
发表回复
niexianhu 2004-04-01
hehe ,你也做AI的开发?
我这里AISDK从8到CS都有。
你用9.0的SDK编译出来的AIP文件8.0的AI当然用不了。
示例代码没问题,编译出来都可以加载。
有问题niexianhu@comnet-network.co.jp
  • 打赏
  • 举报
回复
hell190109 2004-03-24
关注
  • 打赏
  • 举报
回复
发帖
机器视觉

4303

社区成员

图形图像/机器视觉
社区管理员
  • 机器视觉
  • 迪菲赫尔曼
加入社区
帖子事件
创建了帖子
2004-03-24 10:24
社区公告
暂无公告