关于Delphi7升级到Indy10后与Web Service不兼容的问题

daiguan 2005-02-12 02:34:36
Delphi7中自带的Indy是9,现在Indy出了10,2005中带的就是10,我现在把Delphi7中的9升级到了10,并安要求删除了9,但是发现Web Service没法用了,提示缺少某些单元,这些文件都是Indy9自带的单元文件,但是在10中已经被合并,如果把9中的那些文件拷回去,则提示该文件版本不一致.
我想把Delphi2005中的WebService单元拷到Delphi7中用,但怕存在些兼容性问题,不知道大家还有些什么好的解决方法,Indy10比indy9多了很多东西,有不少都是我急需的,同时也变的不少东西,而Delphi中的WebService的运行是需要Indy组件的.
请大家帮忙,最少是有那种针对Indy10并且给Delphi7用的WebService组件升级.
...全文
238 3 打赏 收藏 举报
写回复
3 条回复
切换为时间正序
当前发帖距今超过3年,不再开放新的回复
发表回复
daiguan 2005-02-13
就是在我的机子上没法装2005,所以我才头疼.而且我不可能在短时间内把开发都移植到2005上,毕竟2005还不能兼容7上面的很多专家系统和控件.在老外一网站上查到说要把WebService重新编译一下,因为9和10的Write的写法变了.
  • 打赏
  • 举报
回复
qccxy 2005-02-13
Delphi7和Delphi2005可在一台机子上同时装的。
  • 打赏
  • 举报
回复
耙子 2005-02-12
没用过Indy 10。

要不然你就安装 Delphi 2005
  • 打赏
  • 举报
回复
发帖
网络通信/分布式开发
加入

1585

社区成员

Delphi 网络通信/分布式开发
社区管理员
  • 网络通信/分布式开发社区
申请成为版主
帖子事件
创建了帖子
2005-02-12 02:34
社区公告
暂无公告