请教!我用ojdbc14.jar驱动连接oracle9i数据库,当操作BLOB字段时用了getBinaryOutputStream方法,可是此方法被deprecated???

Oracle > 开发 [问题点数:50分,结帖人CSDN]
等级
本版专家分:0
结帖率 98.58%
luoxiang2000

等级:

保存BLOB类型报java.lang.ClassCastException: oracle.sql.BLOB 的解决办法

默认tomcat的common/lib下是没有 ojdbc14.jar 这个jar包的, ...发布的工程里面需要实现向ORACLE数据库里存入一个BLOB字段时,会用到代码: Java代码 java.sql.Blob blob = rest.getBlob(1

java.sql.SQLException: Protocol violation 问题解析

问题描述:Hibernate 4.0.2Spring 3.2.3ojdbc6oracle使用的是 10.0.2版本系统偶尔会出现以下错误:java.sql.SQLException: Protocol violation: [1] at oracle.jdbc.driver.T4CTTIfun.receive(T4CTTIfun.java:527)...

OJDBC版本区别 [ojdbc14.jarojdbc5.jarojdbc6.jar的区别]

OJDBC版本区别 [ojdbc14.jarojdbc5.jarojdbc6.jar的区别]

MyEclipse环境下如何采用Maven导入ojdbc14.jarojdbc6.jar

阿里数据库连接池druid连接Oracle 11g ...这几天在捣鼓Struts2+Spring3+Hibernate4+Maven+EasyUI的整合,JDK1.7,数据库采用Oracle 11g R2,驱动采用ojdbc14数据库连接池采用阿里巴巴的druid(完整的包名为com.aliba

OJDBC驱动版本区别 [ojdbc14.jarojdbc5.jarojdbc6.jar的区别]

OJDBC版本区别 [ojdbc14.jarojdbc5.jarojdbc6.jar的区别] 在使用Oracle JDBC驱动时,有些问题你是不是通过替换不同版本的Oracle JDBC驱动来解决的?最常使用ojdbc14.jar有多个版本,classes12.jar有多个...

eclipse中使用maven添加oracle驱动依赖

eclipse中使用能够maven引入oracle驱动

maven如何手动导入ojdbc6.jarojdbc14

使用阿里巴巴数据库连接池druid,程序启动的时候报“druid –not support oracle driver 1.0”,换个各种版本驱动(包括ojdbc6),都不行。是因为连接的客户端的版本太低了吗?    就是数据库驱动的版本问题,后来...

JDBC连接Oracle数据库驱动Jar包的手动引入

由于oracle的授权问题,从maven仓库中不能直接下载到jdbc-oracle驱动,因此若项目使用了oralce数据库,则需要手动引入jar包 一、本地配置maven环境变量 由于手动添加jar包,maven识别不了,因此需要利用maven命令...

在Maven仓库中添加Oracle数据库的JDBC驱动依赖

今天在使用IDEA构建Maven项目,发现Oracle数据库JDBC驱动依赖使用不了,就在网上搜索了一下,下面是不能使用的原因。 由于Oracle授权问题,Maven3不提供oracle JDBC driver,我们也可以在Maven的中心搜索ojdbc...

oracle驱动包下载

ojdbc驱动包下载ojdbc5.jarojdbc6.jarojdbc7.jarojdbc8.jarojdbc10.jar下载及其对应的Oracle版本![在这里插入图片描述](https://img-blog.csdnimg.cn/20190924214241525.png?x-oss-process=image/watermark,...

Java使用ojdbc连接Oracle数据库时不能使用服务名连接的问题

最近,在做完数据库迁移后,领导要求所有的前端应用必须使用oracle的服务名连接数据库。所以在迁移数据库之前对公司内部开发系统做了全面准备。但是在迁移数据库的当晚还是遇到了问题,因为忘记考虑第三方的应用系统...

Oracle数据库驱动ojdbc7.jarojdbc8.jar

ojdbc驱动包,可以在这个地址上找到 https://gitee.com/My_better/ojdbc

阿里数据库连接池druid连接Oracle 11g R2报错:not support oracle driver 1.0

JDK1.7,数据库采用Oracle 11g R2,驱动采用ojdbc14数据库连接池采用阿里巴巴的druid(完整的包名为com.alibaba.druid.pool.DruidDataSource),但是在做JUnit做单元测试的时候报如下错误: Caused by

java.sql.SQLException: Protocol violation解析

之前连接oracle数据库总是连接不上,再三检查代码没发现问题,最后看到java.sql.SQLException: Protocol violation 感觉是jdbc jar包出了问题,于是更换了jar包,果然连接再也没报错了。这里附录网上摘抄的关于ojdbc...

Oracle数据库blob类型更新失败处理过程

在执行更新数据库blob字段类型,首先是本地出现问题:Tomcat执行到更新blob字段代码后直接中断,debug跟踪也直接中断debug,控制台不输出任何错误。 2、问题发现 根据问题的现象,初步判断是API的问题,更新...

OJDBC版本【classes12.jarojdbc14.jarojdbc5.jarojdbc6.jar的区别】

classes12.jarojdbc14.jarojdbc5.jarojdbc6.jar的区别,之间的差异   在使用Oracle JDBC驱动时,有些问题你是不是通过替换不同版本的Oracle JDBC驱动来解决的?最常使用ojdbc14.jar有多个版本,classes12....

在 IDEA 中使用 Oracle JDBC 驱动

由于 Oracle 授权问题,Maven 不提供 Oracle JDBC driver,如果想在 Maven 项目中使用 Oracle JDBC Driver,有以下两种方法。一、使用 Maven 引用,需要手动将 Oracle JDBC Driver 添加到本地仓库1、获取 ojdbc...

oracle 11g jdbc jar包在哪个文件目录

oracle 11g jdbc jar包在哪个文件目录 一. 如果装了oracle数据库的话, 大致是这样的目录:  D:\oracle\product\11.2.0\client_1\oui\jlib\classes12.jar 或者  D:\oracle\product\11.2.0\dbhome_1\...

The Network Adapter could not establish the connection问题解决

启动tomcat一直报:The Network Adapter could not establish the connection这个错误,因为以前没有使用oracle开发,所以对解决Oracle抛出的这个错误还有些疑惑,在网上搜索相关解决问题方法,其时大多数解决方法都...

oracle各个版本所需要的ojdbc jar驱动包以及版本对应关系

版本对应关系及使用方法 jar包下载地址 oracle版本 随Oracle版本发布的OracleJDBC驱动 适用JDK Oracle 8i classes111.zip JDK1.1 ...

Oracle各版本(19c, 18c, 12c, 11g)数据库驱动ojdbc.jar下载地址

Java程序猿们对Oracle家的数据库驱动ojdbc.jar想必不会陌生.然而Oracle经常会把一些下载链接隐藏得比较深,比如度娘搜索ojdbc出来的结果可能还是对应11g的版本.正好公司数据库升级到19c,更新驱动顺手记录一下下载链接...

ireport连接ORACLE

采用JDBC的方式连接Oracle 10g数据库,出现: java.lang.ClassNotFoundException: oracle.jdbc.driver.OracleDriver错误   原因是iReport没有找到Oracle10g的jdbc驱动,iReport中并没有内置Oreacle10g...

oracle连接数据库jar包(ojdbc10.jarojdbc8.jarojdbc6.jar

链接:https://pan.baidu.com/s/1agHs5vWeXf90r3OEeVGniw 提取码:wsgm 复制这段内容后打开百度网盘手机App,操作更方便哦

Missing artifact oracle:ojdbc:jar:14:compile

这几天在捣鼓Struts2+Spring3+Hibernate4+Maven+EasyUI的整合,采用Oracle数据库Oracle数据库驱动采用ojdbc14,后来因为数据库连接池采用阿里巴巴的druid,其中可能存在版本问题而换成了ojdbc6。本文主要介绍...

Oracle:错误码ORA-28040 的坑

因项目要求,第一次部署了Oracle 12 C的Server,Linux CentOS版,数据库装好之后部署一个Java Web项目(A项目)去连接数据库,该Java项目之前Oracle是11 g版本,这次换成了12 C的版本,日志显示的错误信息如下:...

IDEA 连接 ORACLE 的配置(OJDBC14通过pom配置, OJDBC7通过library配置)

最近查询一个数据需要连接数据库去查询,因为没有使用OJDBC驱动包,所以去百度了一下 了解到了两种方法 1.是配置到POM文件 2.是使用IDEA的Project Consruct 去导进library。 1.使用POM文件配置如下: 可以...

maven 添加ojdbcojdbc的各种版本说明

在做mybatis generator的中文注释实现,感觉每次都要在配置文件中指定ojdbc6的位置太麻烦了,别人也不方便,没有的还得自己去下,所以就想直接把ojdbc6打包到项目里,这样拿到就可以直接了,但是maven的仓库中是没有...

Visio_2016

visio_2016下载安装,亲测可用,不需要破解,而且无秘钥。简单方便实用

Xshell6完美破解版,亲测可用

Xshell6破解版,亲测可用,分享给大家。直接解压即可使用

个人简历模板

优质简历模板,目前最前全的模板收藏,需要换工作的小伙伴们可以试试

相关热词 c# 为窗体增加资源文件 c#控制器怎么提示 c#常见异常 c#怎么写人机 c# xml转json c# 实例化名字 c#循环嵌套if语句 c# sql日期最小时间 c# sql 读取数据 c# 获取基类型